summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordaurnimator2018-08-16 22:59:09 +1000
committerdaurnimator2018-08-16 22:59:09 +1000
commitedcb206e22c6146721744ae7ea110e8c7191cb40 (patch)
tree7de4f230ed6f2d5c971c91a96bbe035beb9e684d
downloadaur-edcb206e22c6146721744ae7ea110e8c7191cb40.tar.gz
Initial packaging of 2.0 release
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD27
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..81ce594797b8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = pllua-ng
+ pkgdesc = PL/Lua is a procedural language module for the PostgreSQL database that allows server-side functions to be written in Lua
+ pkgver = 2.0
+ pkgrel = 0
+ url = https://pllua.github.io/pllua-ng/
+ arch = x86_64
+ license = MIT
+ depends = lua
+ depends = postgresql
+ source = https://github.com/RhodiumToad/pllua-ng/archive/REL_2_0.tar.gz
+ md5sums = f4dc3a643513c59a9830ab1ff2e1f07c
+
+pkgname = pllua-ng
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..64e0a4ff0c4c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Daurnimator <quae@daurnimator.com>
+
+pkgname=pllua-ng
+pkgver=2.0
+pkgrel=0
+pkgdesc='PL/Lua is a procedural language module for the PostgreSQL database that allows server-side functions to be written in Lua'
+arch=('x86_64')
+url='https://pllua.github.io/pllua-ng/'
+license=('MIT')
+depends=('lua' 'postgresql')
+source=("https://github.com/RhodiumToad/pllua-ng/archive/REL_2_0.tar.gz")
+md5sums=('f4dc3a643513c59a9830ab1ff2e1f07c')
+
+build() {
+ cd pllua-ng-REL_2_0
+
+ make LUA=lua LUAC=luac LUA_INCDIR=/usr/include LUALIB=-llua
+ make -C hstore LUA=lua LUAC=luac LUA_INCDIR=/usr/include LUALIB=-llua
+}
+
+package() {
+ cd pllua-ng-REL_2_0
+
+ make DESTDIR="$pkgdir" install
+ make -C hstore DESTDIR="$pkgdir" install
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}