summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFermín Olaiz2024-02-01 15:25:20 -0300
committerFermín Olaiz2024-02-01 15:25:20 -0300
commit570cc4057526f73c0a953007d193d0b297d9a1b4 (patch)
treea15edf8dc5bc7191846cd411af2ba84edf46c40f
parent9e4071b06b9efccfef46cb2fa92253400a99d0ff (diff)
downloadaur-570cc4057526f73c0a953007d193d0b297d9a1b4.tar.gz
ploop: update pkg to 9.0.21, fix syscalls
-rw-r--r--PKGBUILD17
-rw-r--r--fix-static-syscalls.patch19
2 files changed, 32 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a12fa6e4d89e..1a6b37f15e4d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,29 @@
-# Maintainer: Pavel Borzenkov <pavel@voidptr.ru>
+# Maintainer: Fermín Olaiz <ferminolaiz@gmail.com>
+
pkgname=ploop
-pkgver=7.0.38
+pkgver=9.0.21
pkgrel=1
pkgdesc="Disk loopback block device with many features like dynamic resize, snapshots, etc."
url="https://openvz.org/Ploop"
license=('GPL2' 'LGPL2.1')
arch=("x86_64")
-source=("git+https://src.openvz.org/scm/ovz/ploop.git#tag=v${pkgver}")
+source=(
+ "git+https://src.openvz.org/scm/ovz/ploop.git#tag=v${pkgver}"
+ "fix-static-syscalls.patch"
+)
install=ploop.install
depends=('libxml2' 'python' 'libutil-linux' 'bash')
makedepends=('git')
-md5sums=('SKIP')
+sha256sums=(
+ "SKIP"
+ "5889a0b448ddc5a93a846cb651e5081ae5e7962b04deaf5c713e1c78de3662c3"
+)
build() {
cd "${srcdir}/${pkgname}"
+ git apply ../fix-static-syscalls.patch
+
make
}
diff --git a/fix-static-syscalls.patch b/fix-static-syscalls.patch
new file mode 100644
index 000000000000..df77ab1a1ee2
--- /dev/null
+++ b/fix-static-syscalls.patch
@@ -0,0 +1,19 @@
+diff --git a/lib/ploop.c b/lib/ploop.c
+index 286f213..95c40df 100644
+--- a/lib/ploop.c
++++ b/lib/ploop.c
+@@ -2587,12 +2587,12 @@ static int do_mount(const char *part, const char *target)
+ }
+
+
+-static int open_tree(int dirfd, const char *pathname, unsigned int flags)
++int open_tree(int dirfd, const char *pathname, unsigned int flags)
+ {
+ return syscall(428, dirfd, pathname, flags);
+ }
+
+-static int move_mount(int from_dirfd, const char *from_pathname, int to_dirfd,
++int move_mount(int from_dirfd, const char *from_pathname, int to_dirfd,
+ const char *to_pathname, unsigned int flags)
+ {
+ return syscall(429, from_dirfd, from_pathname, to_dirfd, to_pathname, flags);