summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMoses Narrow2022-10-13 13:22:27 -0500
committerMoses Narrow2022-10-13 13:22:27 -0500
commit6805ae0ed96240a46d67d6dd9824860873558bda (patch)
tree14a8a5e742ee3dd84bad409de05056ace90ab5a2
downloadaur-6805ae0ed96240a46d67d6dd9824860873558bda.tar.gz
first commit, add PKGBUILD .SRCINFO updates.sh
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD46
-rwxr-xr-xupdates.sh6
3 files changed, 78 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..57c2df270efc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = plot-git
+ pkgdesc = plot on the command line
+ pkgver = 0.5.1
+ pkgrel = 1
+ url = https://github.com/annacrombie/plot
+ arch = i686
+ arch = x86_64
+ arch = aarch64
+ arch = armv8
+ arch = armv7
+ arch = armv7l
+ arch = armv7h
+ arch = armv6h
+ arch = armhf
+ arch = armel
+ arch = arm
+ license = license-free
+ makedepends = git
+ makedepends = meson
+ makedepends = pkgconfig
+ makedepends = cmake
+ makedepends = scdoc
+ source = git+https://github.com/annacrombie/plot.git
+ sha256sums = SKIP
+
+pkgname = plot-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b2e0eb1db9b6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Moses Narrow <moe_narrow@skycoin.com>
+pkgname=plot-git
+_pkgname=${pkgname/-git/}
+_githuborg=annacrombie
+pkgdesc="plot on the command line"
+#https://github.com/annacrombie/plot
+_pkgpath="github.com/${_githuborg}/${_pkgname}"
+pkgver=0.5.1
+pkgrel=1
+arch=( 'i686' 'x86_64' 'aarch64' 'armv8' 'armv7' 'armv7l' 'armv7h' 'armv6h' 'armhf' 'armel' 'arm' )
+url="https://${_pkgpath}"
+license=('license-free')
+makedepends=('git' 'meson' 'pkgconfig' 'cmake' 'scdoc')
+source=("git+${url}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+_version=$(git ls-remote --tags --refs --sort="version:refname" ${url}.git | tail -n1)
+_version=${_version##*/}
+_version=${_version%%-*}
+_version=${_version//v/}
+if [[ ${_version} == "" ]] ; then
+ _version="0.0.1"
+fi
+echo ${_version}
+}
+
+build() {
+cd ${srcdir}/${_pkgname}
+meson build
+meson compile -C build
+}
+
+package() {
+_msg2 "installing files"
+install -Dm755 ${srcdir}/${_pkgname}/build/lib/libplot.so ${pkgdir}/usr/lib/libplot.so
+install -Dm755 ${srcdir}/${_pkgname}/build/cli/plot ${pkgdir}/usr/bin/${_pkgname}
+install -Dm755 ${srcdir}/${_pkgname}/include/plot/plot.h ${pkgdir}/usr/include/plot/plot.h
+install -Dm755 ${srcdir}/${_pkgname}/include/plot/file_input.h ${pkgdir}/usr/include/plot/file_input.h
+}
+
+_msg2() {
+(( QUIET )) && return
+local mesg=$1; shift
+printf "${BLUE} ->${ALL_OFF}${BOLD} ${mesg}${ALL_OFF}\n" "$@"
+}
diff --git a/updates.sh b/updates.sh
new file mode 100755
index 000000000000..497179bbbaae
--- /dev/null
+++ b/updates.sh
@@ -0,0 +1,6 @@
+#!/bin/bash
+makepkg --printsrcinfo > .SRCINFO
+source PKGBUILD && echo "pkgname=${pkgname}" && echo "pkgver=${pkgver}" && echo "pkgrel=${pkgrel}"
+echo
+echo "git add -f" *PKGBUILD " .SRCINFO updates.sh"
+echo 'git commit -m " "'