summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcarlwgeorge2017-04-25 15:12:00 -0500
committercarlwgeorge2017-04-25 15:17:47 -0500
commitb06fa58770e1cd660b9ba8172bc2195958e72e79 (patch)
treedf36f81b913f3810f68765ca26061f8f4ecb12c8
downloadaur-b06fa58770e1cd660b9ba8172bc2195958e72e79.tar.gz
0.1.0-1
-rw-r--r--.SRCINFO21
-rw-r--r--.gitignore10
-rw-r--r--PKGBUILD27
-rw-r--r--plotinus.sh1
4 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fa6efc9e15f9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+# Generated by mksrcinfo v8
+# Tue Apr 25 20:16:52 UTC 2017
+pkgbase = plotinus
+ pkgdesc = A searchable command palette in every modern GTK+ application
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://github.com/p-e-w/plotinus
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = vala>=0.26
+ makedepends = cmake>=2.8
+ makedepends = gtk3>=3.16
+ source = https://github.com/p-e-w/plotinus/archive/v0.1.0/plotinus-0.1.0.tar.gz
+ source = plotinus.sh
+ sha256sums = a87a0da53e3c048fb2fbb20d2b9358058b2428f0b7609930e62f63927cb04a60
+ sha256sums = 96fad14ace388edf164b5158adb507765b2bd1fe5c9435c41081ffa8ac2cec11
+
+pkgname = plotinus
+ depends = gtk3>=3.16
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..213d7dad80c7
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,10 @@
+# sources
+*.tar.gz
+
+# build logs
+*-build.log
+*-namcap.log
+*-package*.log
+
+# packages
+*.pkg.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c64609777f07
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Carl George < arch at cgtx dot us >
+
+pkgname=plotinus
+pkgver=0.1.0
+pkgrel=1
+pkgdesc='A searchable command palette in every modern GTK+ application'
+arch=('i686' 'x86_64')
+url='https://github.com/p-e-w/plotinus'
+license=('GPL3')
+makedepends=('vala>=0.26' 'cmake>=2.8' 'gtk3>=3.16')
+source=("https://github.com/p-e-w/plotinus/archive/v$pkgver/$pkgname-$pkgver.tar.gz"
+ "plotinus.sh")
+sha256sums=('a87a0da53e3c048fb2fbb20d2b9358058b2428f0b7609930e62f63927cb04a60'
+ '96fad14ace388edf164b5158adb507765b2bd1fe5c9435c41081ffa8ac2cec11')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ cmake .
+ make
+}
+
+package() {
+ depends=('gtk3>=3.16')
+ cd "$srcdir/$pkgname-$pkgver"
+ install -D --mode 0755 --target-directory "$pkgdir/usr/lib" libplotinus.so
+ install -D --mode 0644 --target-directory "$pkgdir/etc/profile.d" ../plotinus.sh
+}
diff --git a/plotinus.sh b/plotinus.sh
new file mode 100644
index 000000000000..95ba6b06013e
--- /dev/null
+++ b/plotinus.sh
@@ -0,0 +1 @@
+export GTK3_MODULES="${GTK3_MODULES:+$GTK3_MODULES:}/usr/lib/libplotinus.so"