summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoritsagoodbrain2021-01-11 06:58:24 -0500
committeritsagoodbrain2021-01-11 06:58:24 -0500
commit2e45b411c47371b37b0107154636d553f912ccb7 (patch)
treee51d29703c0af7ccdc9030a3e14d43498eaed41a
parentf6761d85f107d379b5f9af6a24ad560a17834a03 (diff)
downloadaur-2e45b411c47371b37b0107154636d553f912ccb7.tar.gz
simplify pkgbuild because no desktop files needed
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD27
2 files changed, 3 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6160728221c1..7bad21bf8830 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = plotly-orca-appimage
pkgdesc = Command line application for generating static images of interactive plotly charts
pkgver = 1.3.1
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/plotly/orca
arch = x86_64
license = MIT
diff --git a/PKGBUILD b/PKGBUILD
index 1f330a63d9a7..f0398f9bf06c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,10 @@
-# Based on the template from https://daveparrish.net/posts/2019-11-16-Better-AppImage-PKGBUILD-template.html
# Maintainer: itsagoodbrain <itsrottenisay@gmail.com>
_pkgname=orca
pkgname=plotly-"${_pkgname}"-appimage
pkgver=1.3.1
-pkgrel=1
+pkgrel=2
pkgdesc="Command line application for generating static images of interactive plotly charts"
arch=('x86_64')
url="https://github.com/plotly/orca"
@@ -24,32 +23,10 @@ sha512sums=(
'SKIP'
)
-prepare() {
- chmod +x "${_appimage}"
- ./"${_appimage}" --appimage-extract
-}
-
-build() {
- # Adjust .desktop so it will work outside of AppImage container
- sed -i -E "s|Exec=AppRun|Exec=env DESKTOPINTEGRATION=false /usr/bin/${_pkgname} %u|"\
- "squashfs-root/${_pkgname}.desktop"
-
- # Fix permissions; .AppImage permissions are 700 for all directories
- chmod -R a-x+rX squashfs-root/usr
-}
-
package() {
# AppImage
install -Dm755 "${srcdir}/${_appimage}" "${pkgdir}/opt/${pkgname}/${pkgname}.AppImage"
-
- # Desktop file
- install -Dm644 "${srcdir}/squashfs-root/${_pkgname}.desktop"\
- "${pkgdir}/usr/share/applications/${_pkgname}.desktop"
-
- # Icon images
- install -dm755 "${pkgdir}/usr/share/"
- cp -a "${srcdir}/squashfs-root/usr/share/icons" "${pkgdir}/usr/share/"
-
+
# Symlink executable
install -dm755 "${pkgdir}/usr/bin"
ln -s "/opt/${pkgname}/${pkgname}.AppImage" "${pkgdir}/usr/bin/${_pkgname}"