summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOndřej Hlavatý2017-02-21 09:08:13 +0100
committerOndřej Hlavatý2017-02-21 09:10:40 +0100
commit5e549b8086b6259a19fe60ff6c7560358ed691bd (patch)
tree18592c550dc75e0182dfabb5f8014e0c80a0094e
downloadaur-5e549b8086b6259a19fe60ff6c7560358ed691bd.tar.gz
Package plotnetcfg-v0.4.1
This is the most current version released, though its a bit old. We patch the Makefile to allow changing compilator options and adjust locations where to put binaries. Signed-off-by: Ondřej Hlavatý <ohlavaty@redhat.com>
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD32
-rw-r--r--plotnetcfg-v0.4.1.patch23
3 files changed, 72 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..01e6eddeda1c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = plotnetcfg
+ pkgdesc = A tool to dump and visualize complex network configuration.
+ pkgver = 0.4.1
+ pkgrel = 1
+ url = https://github.com/jbenc/plotnetcfg
+ arch = x86
+ arch = x86_64
+ license = GPL
+ depends = jansson>=2.3
+ optdepends = graphviz: to actually draw the diagrams
+ source = https://github.com/jbenc/plotnetcfg/archive/v0.4.1.tar.gz
+ source = plotnetcfg-v0.4.1.patch
+ sha1sums = eb5da7dfb954cf5733c9eb546fe14f063d66c0a3
+ sha1sums = 6e4c9cdc516e75a9c316452319551991c4d6229e
+
+pkgname = plotnetcfg
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2722d7e49999
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Ondřej Hlavatý <ohlavaty at redhat dot com>
+pkgname=plotnetcfg
+pkgver=0.4.1
+pkgrel=1
+pkgdesc="A tool to dump and visualize complex network configuration."
+arch=('x86' 'x86_64')
+url="https://github.com/jbenc/plotnetcfg"
+license=('GPL')
+depends=('jansson>=2.3')
+optdepends=('graphviz: to actually draw the diagrams')
+source=(
+ "https://github.com/jbenc/plotnetcfg/archive/v$pkgver.tar.gz"
+ "plotnetcfg-v0.4.1.patch"
+)
+sha1sums=('eb5da7dfb954cf5733c9eb546fe14f063d66c0a3'
+ '6e4c9cdc516e75a9c316452319551991c4d6229e')
+BUILDENV+=('!check')
+
+prepare() {
+ cd "$pkgname-$pkgver"
+ patch -p1 <../$pkgname-v$pkgver.patch
+}
+
+build() {
+ cd "$pkgname-$pkgver"
+ make CC=gcc
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+}
diff --git a/plotnetcfg-v0.4.1.patch b/plotnetcfg-v0.4.1.patch
new file mode 100644
index 000000000000..dfec57bbd8b2
--- /dev/null
+++ b/plotnetcfg-v0.4.1.patch
@@ -0,0 +1,23 @@
+diff -Naur plotnetcfg-0.4.1.raw/Makefile plotnetcfg-0.4.1/Makefile
+--- plotnetcfg-0.4.1/Makefile 2015-07-27 11:07:56.000000000 +0200
++++ plotnetcfg-0.4.1.patched/Makefile 2017-01-28 13:32:02.860196078 +0100
+@@ -4,7 +4,7 @@
+ libs=$(jansson)/src/.libs/libjansson.a
+ INCLUDE=-I$(jansson)/src
+ endif
+-CFLAGS=-W -Wall $(INCLUDE)
++CFLAGS+=$(INCLUDE)
+
+ all: check-libs plotnetcfg
+
+@@ -46,8 +46,8 @@
+ rm -f version.h *.o frontends/*.o handlers/*.o plotnetcfg
+
+ install: plotnetcfg
+- install -d $(DESTDIR)/usr/sbin/
+- install plotnetcfg $(DESTDIR)/usr/sbin/
++ install -d $(DESTDIR)/usr/bin/
++ install plotnetcfg $(DESTDIR)/usr/bin/
+ install -d $(DESTDIR)/usr/share/man/man8/
+ install -d $(DESTDIR)/usr/share/man/man5/
+ install -m 644 plotnetcfg.8 $(DESTDIR)/usr/share/man/man8/