summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBenoit Pierre2016-05-02 17:30:46 +0200
committerBenoit Pierre2016-05-02 17:30:46 +0200
commit085aedaa9c2072f89e0f4c4972abdb04c93f504e (patch)
tree61ba14846dfbf7f7f40e3482eb54f330d0084de0
parent44cc45aa85553283680bc37f1640d0ca0b001dd0 (diff)
downloadaur-085aedaa9c2072f89e0f4c4972abdb04c93f504e.tar.gz
update to lastest stable release: 3.0.0
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD48
2 files changed, 47 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 520edf7c0907..1e634443d986 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,24 +1,26 @@
-# Generated by mksrcinfo v8
-# Thu Jan 7 08:17:25 UTC 2016
pkgbase = plover
pkgdesc = Free and open source real-time stenography engine.
- pkgver = 2.5.8
+ pkgver = 3.0.0
pkgrel = 1
- url = https://www.openstenoproject.org
+ url = http://www.openstenoproject.org/plover/
arch = any
- license = GPLv2
+ license = GPL2
+ makedepends = python2-mock
+ makedepends = python2-pytest
+ makedepends = python2-pytest-runner
depends = python2
+ depends = python2-appdirs
+ depends = python2-hidapi
+ depends = python2-pyserial
depends = python2-setuptools
- depends = wxpython
+ depends = python2-simplejson
depends = python2-xlib
depends = wmctrl
- depends = python2-simplejson
- depends = python2-pyserial
- depends = python2-appdirs
+ depends = wxpython
provides = plover
conflicts = plover-git
- source = https://github.com/openstenoproject/plover/archive/v2.5.8.tar.gz
- md5sums = 07baf37d3bd9b888ffe54fd598b93e10
+ source = https://github.com/openstenoproject/plover/archive/v3.0.0.tar.gz
+ sha1sums = 89ca6af3fe002be218158930d105d25c1e1282be
pkgname = plover
diff --git a/PKGBUILD b/PKGBUILD
index ffe19d780ccb..520eac08d3e9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,42 @@
+# Maintainer: Benoit Pierre <benoit.pierre@gmail.com>
+
pkgname=plover
-pkgver=2.5.8
-pkgrel=1
pkgdesc="Free and open source real-time stenography engine."
-arch=(any)
-url="https://www.openstenoproject.org"
-license=('GPLv2')
-groups=()
-depends=('python2' 'python2-setuptools' 'wxpython' 'python2-xlib' 'wmctrl'
- 'python2-simplejson' 'python2-pyserial' 'python2-appdirs')
-makedepends=()
+pkgver=3.0.0
+pkgrel=1
+arch=('any')
+license=('GPL2')
+depends=(
+ 'python2'
+ 'python2-appdirs'
+ 'python2-hidapi'
+ 'python2-pyserial'
+ 'python2-setuptools'
+ 'python2-simplejson'
+ 'python2-xlib'
+ 'wmctrl'
+ 'wxpython'
+)
+makedepends=(
+ 'python2-mock'
+ 'python2-pytest'
+ 'python2-pytest-runner'
+)
provides=('plover')
conflicts=('plover-git')
-backup=()
-options=()
+url="http://www.openstenoproject.org/plover/"
source=("https://github.com/openstenoproject/plover/archive/v$pkgver.tar.gz")
-md5sums=('07baf37d3bd9b888ffe54fd598b93e10')
+sha1sums=(89ca6af3fe002be218158930d105d25c1e1282be)
+
+check() {
+ cd "$pkgname-$pkgver"
+ python2 setup.py test
+}
package() {
- cd plover-$pkgver
- python2 setup.py install --root="$pkgdir"
+ cd "$pkgname-$pkgver"
+ python2 setup.py install --root="$pkgdir"
+ chmod og+rX -R "$pkgdir"
}
+
+# vim:set sw=2 sts=2 et: