summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormarco442019-04-10 15:24:24 +0200
committermarco442019-04-10 15:25:31 +0200
commit36a0c9e3f702355b22795b28d1a44b923974ef9a (patch)
tree3576fe2a4d75b1a6f17e8b1b21b2ce3d01894fa7
downloadaur-36a0c9e3f702355b22795b28d1a44b923974ef9a.tar.gz
Init
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD37
2 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..841e62d63a24
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = plpgsql_check
+ pkgdesc = linter for PostgreSQL's procedural language
+ pkgver = 6a8074e
+ pkgrel = 1
+ url = https://github.com/okbob/plpgsql_check
+ arch = i686
+ arch = x86_64
+ arch = armv7h
+ arch = aarch64
+ license = Postcardware
+ makedepends = git
+ makedepends = llvm
+ depends = postgresql
+ options = !emptydirs
+ options = !libtool
+ source = git://github.com/okbob/plpgsql_check
+ md5sums = SKIP
+
+pkgname = plpgsql_check-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..23d713fe5aca
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Marco44 (Marc Cousin) <cousinmarc at gmail dot com>
+pkgname=plpgsql_check-git
+pkgbase=plpgsql_check
+_gitname=plpgsql_check
+pkgver=6a8074e
+pkgrel=1
+pkgdesc="linter for PostgreSQL's procedural language"
+arch=('i686' 'x86_64' 'armv7h' 'aarch64')
+url="https://github.com/okbob/plpgsql_check"
+license=('Postcardware')
+depends=('postgresql')
+builddepends=()
+makedepends=(git llvm)
+options=(!emptydirs !libtool)
+source=('git://github.com/okbob/plpgsql_check')
+md5sums=('SKIP')
+install=''
+
+pkgver() {
+ cd $_gitname
+ tag=`git tag | grep REL | tail -1`
+ commit=`git log --format="%h" -n 1`
+ echo "$tag_$commit"
+}
+
+build() {
+ local _gitdir=$srcdir/$_gitname
+ cd $_gitdir
+ git clean -dfx
+ git reset --hard
+ make
+}
+
+package() {
+ cd $srcdir/$_gitname
+ make DESTDIR=$pkgdir install
+}