summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMiguel de Val-Borro2015-07-09 14:57:40 -0400
committerMiguel de Val-Borro2015-07-09 14:58:16 -0400
commit503d90d628312ddc3370052e5dc45f407c72d463 (patch)
tree1a0cf1e6e8535a254d893bb0977b1c5d6c52a272
downloadaur-503d90d628312ddc3370052e5dc45f407c72d463.tar.gz
Initial commit
-rw-r--r--.SRCINFO30
-rw-r--r--PKGBUILD48
-rw-r--r--plplot.patch87
3 files changed, 165 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0a60b8703853
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,30 @@
+pkgbase = plplot
+ pkgdesc = A cross-platform software package for creating scientific plots
+ pkgver = 5.10.0
+ pkgrel = 4
+ url = http://plplot.sourceforge.net/
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ license = custom
+ makedepends = cmake
+ depends = libtool
+ depends = tk
+ optdepends = qhull: calculating convex hulls
+ optdepends = agg: high quality rendering engine in C++
+ optdepends = swig: connects Plplot C library to Python, Java and Lua (must be present at compile time for Java)
+ optdepends = gd: ability to output png, jpeg and gif files
+ optdepends = qt4: display plots, output various formats using the Qt UI framework
+ optdepends = wxgtk: displays plots using wxWidgets library
+ optdepends = freetype2: enables use of ttf fonts for some drivers
+ optdepends = ttf-freefont: enables use of ttf fonts for some drivers
+ optdepends = cairo: displays plots and save to different file formats
+ options = !libtool
+ options = !makeflags
+ source = http://downloads.sourceforge.net/sourceforge/plplot/plplot-5.10.0.tar.gz
+ source = plplot.patch
+ md5sums = ece8c0b4d5cd815968a6d56bed0fbe7b
+ md5sums = 9a50d8aa4c088bd29355076f6fc91f31
+
+pkgname = plplot
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9e717b5eb345
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Maintainer: James Tappin <jtappinatgmaildotcom>
+# Contributor: Gergely Imreh <imrehgATgmailDOTcom>
+# Contributor: Eric Belanger <eric@archlinux.org>
+pkgname=plplot
+pkgver=5.10.0
+pkgrel=4
+pkgdesc="A cross-platform software package for creating scientific plots"
+arch=('i686' 'x86_64')
+url="http://plplot.sourceforge.net/"
+license=("LGPL" "custom")
+depends=('libtool' 'tk')
+makedepends=('cmake')
+optdepends=('qhull: calculating convex hulls'
+ 'agg: high quality rendering engine in C++'
+ 'swig: connects Plplot C library to Python, Java and Lua (must be present at compile time for Java)'
+ 'gd: ability to output png, jpeg and gif files'
+ 'qt4: display plots, output various formats using the Qt UI framework'
+ 'wxgtk: displays plots using wxWidgets library'
+ 'freetype2: enables use of ttf fonts for some drivers'
+ 'ttf-freefont: enables use of ttf fonts for some drivers'
+ 'cairo: displays plots and save to different file formats')
+options=('!libtool' '!makeflags')
+source=(http://downloads.sourceforge.net/sourceforge/plplot/${pkgname}-${pkgver}.tar.gz \
+ plplot.patch)
+
+build() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ patch -p1 < ../../plplot.patch
+ if [ -d build ]; then
+ rm -r build
+ fi
+ mkdir build
+ cd build
+ cmake -DCMAKE_INSTALL_PREFIX=/usr \
+ -DENABLE_octave=off \
+ -DENABLE_tcl=ON \
+ -DENABLE_tk=ON \
+ -DPL_FREETYPE_FONT_PATH=/usr/share/fonts/TTF ..
+ make
+}
+
+package() {
+ cd ${srcdir}/${pkgname}-${pkgver}/build
+ make DESTDIR=${pkgdir} install
+ install -D -m644 ../Copyright ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+}
+md5sums=('ece8c0b4d5cd815968a6d56bed0fbe7b' \
+ '9a50d8aa4c088bd29355076f6fc91f31')
diff --git a/plplot.patch b/plplot.patch
new file mode 100644
index 000000000000..944eed5a3fda
--- /dev/null
+++ b/plplot.patch
@@ -0,0 +1,87 @@
+--- ./examples/CMakeLists.txt~ 2014-02-06 05:04:19.000000000 +0000
++++ ./examples/CMakeLists.txt 2014-10-18 12:37:48.230640851 +0100
+@@ -414,7 +414,7 @@
+ endif(CORE_BUILD)
+
+ if(CORE_BUILD AND BUILD_TEST)
+- remove_definitions("-DHAVE_CONFIG_H")
++ remove_definitions("-DPLPLOT_HAVE_CONFIG_H")
+ endif(CORE_BUILD AND BUILD_TEST)
+
+ # Decide on device to be used for generic interactive tests.
+--- ./bindings/ocaml/CMakeLists.txt~ 2013-10-22 18:47:13.000000000 +0100
++++ ./bindings/ocaml/CMakeLists.txt 2014-10-18 12:38:33.277573399 +0100
+@@ -99,7 +99,7 @@
+ ${CMAKE_CURRENT_BINARY_DIR}/dllplplot_stubs.so
+ ${CMAKE_CURRENT_BINARY_DIR}/libplplot_stubs.a
+ COMMAND ${OCAMLC} -ccopt -I${CAMLIDL_LIB_DIR} -c ${CMAKE_CURRENT_BINARY_DIR}/plplot_core_stubs.c
+- COMMAND ${OCAMLC} -ccopt -I${CMAKE_SOURCE_DIR}/include -ccopt -I${CMAKE_BINARY_DIR}/include -ccopt -I${CMAKE_SOURCE_DIR}/lib/qsastime -ccopt -I${CMAKE_BINARY_DIR} -ccopt -I${CAMLIDL_LIB_DIR} -ccopt -DHAVE_CONFIG_H -c ${CMAKE_CURRENT_SOURCE_DIR}/plplot_impl.c
++ COMMAND ${OCAMLC} -ccopt -I${CMAKE_SOURCE_DIR}/include -ccopt -I${CMAKE_BINARY_DIR}/include -ccopt -I${CMAKE_SOURCE_DIR}/lib/qsastime -ccopt -I${CMAKE_BINARY_DIR} -ccopt -I${CAMLIDL_LIB_DIR} -ccopt -DPLPLOT_HAVE_CONFIG_H -c ${CMAKE_CURRENT_SOURCE_DIR}/plplot_impl.c
+ COMMAND ${OCAMLMKLIB} -o plplot_stubs -L${CAMLIDL_LIB_DIR} -lcamlidl -L${CMAKE_BINARY_DIR}/src -lplplot${LIB_TAG} ${CMAKE_CURRENT_BINARY_DIR}/plplot_core_stubs.o ${CMAKE_CURRENT_BINARY_DIR}/plplot_impl.o ${ocaml_STATIC_FLAGS}
+ DEPENDS
+ ${CMAKE_CURRENT_BINARY_DIR}/plplot_core_stubs.c
+--- ./bindings/ocaml/plcairo/CMakeLists.txt~ 2013-10-22 18:47:13.000000000 +0100
++++ ./bindings/ocaml/plcairo/CMakeLists.txt 2014-10-18 12:39:03.217750051 +0100
+@@ -36,7 +36,7 @@
+ ${CMAKE_CURRENT_BINARY_DIR}/plcairo_impl.o
+ ${CMAKE_CURRENT_BINARY_DIR}/dllplcairo_stubs.so
+ ${CMAKE_CURRENT_BINARY_DIR}/libplcairo_stubs.a
+- COMMAND ${OCAMLC} -ccopt "${CAIRO_COMPILE_FLAGS}" -cclib "${CAIRO_LINK_FLAGS}" -ccopt -I${CMAKE_SOURCE_DIR}/include -ccopt -I${CMAKE_BINARY_DIR}/include -ccopt -I${CMAKE_SOURCE_DIR}/lib/qsastime -ccopt -I${CMAKE_BINARY_DIR} -ccopt -DHAVE_CONFIG_H -c ${CMAKE_CURRENT_SOURCE_DIR}/plcairo_impl.c
++ COMMAND ${OCAMLC} -ccopt "${CAIRO_COMPILE_FLAGS}" -cclib "${CAIRO_LINK_FLAGS}" -ccopt -I${CMAKE_SOURCE_DIR}/include -ccopt -I${CMAKE_BINARY_DIR}/include -ccopt -I${CMAKE_SOURCE_DIR}/lib/qsastime -ccopt -I${CMAKE_BINARY_DIR} -ccopt -DPLPLOT_HAVE_CONFIG_H -c ${CMAKE_CURRENT_SOURCE_DIR}/plcairo_impl.c
+ COMMAND ${OCAMLMKLIB} -o plcairo_stubs ${CAIRO_LINK_FLAGS_LIST} -L${CMAKE_BINARY_DIR}/src -lplplot${LIB_TAG} ${CMAKE_CURRENT_BINARY_DIR}/plcairo_impl.o
+ DEPENDS
+ ${CMAKE_CURRENT_SOURCE_DIR}/plcairo_impl.c
+--- ./plplot_config.h.in~ 2014-01-13 03:27:10.000000000 +0000
++++ ./plplot_config.h.in 2014-10-18 12:39:42.821316972 +0100
+@@ -3,7 +3,7 @@
+ // examples (and presumably any user applications). Therefore, the
+ // configured plplot_config.h should not be installed. In contrast,
+ // include/plConfig.h.in (note, the configured plConfig.h result
+-// #includes plplot_config.h for the core build because HAVE_CONFIG_H
++// #includes plplot_config.h for the core build because PLPLOT_HAVE_CONFIG_H
+ // is #defined in that case) contains configured macros that are
+ // required for the core build, installed examples build, and build of
+ // user applications. Therefore, in contrast to plplot_config.h,
+--- ./include/plConfig.h.in~ 2013-12-29 20:11:07.000000000 +0000
++++ ./include/plConfig.h.in 2014-10-18 12:40:03.134770083 +0100
+@@ -30,7 +30,7 @@
+ // any user applications). Therefore, the configured plConfig.h
+ // should be installed. In contrast, plplot_config.h.in (note,
+ // plConfig.h #includes plplot_config.h for the core build because
+-// HAVE_CONFIG_H is #defined in that case) contains configured macros
++// PLPLOT_HAVE_CONFIG_H is #defined in that case) contains configured macros
+ // that are only required for the core build. Therefore, in contrast
+ // to plConfig.h, plplot_config.h should not be installed.
+ //
+@@ -44,7 +44,7 @@
+ #ifndef __PLCONFIG_H__
+ #define __PLCONFIG_H__
+
+-#ifdef HAVE_CONFIG_H
++#ifdef PLPLOT_HAVE_CONFIG_H
+ # include <plplot_config.h>
+ #endif
+
+--- ./CMakeLists.txt~ 2013-12-29 20:11:07.000000000 +0000
++++ ./CMakeLists.txt 2014-10-18 12:40:28.278251641 +0100
+@@ -125,7 +125,7 @@
+ ${CMAKE_CURRENT_BINARY_DIR}/plplot_config.h
+ )
+ # Allow access to the generated plplot_config.h for this build.
+-add_definitions("-DHAVE_CONFIG_H")
++add_definitions("-DPLPLOT_HAVE_CONFIG_H")
+ # Install top-level files
+
+ # Enable testing framework for examples
+--- ./cmake/modules/pkg-config.cmake.old 2014-02-06 05:06:07.000000000 +0000
++++ ./cmake/modules/pkg-config.cmake 2015-02-11 18:23:57.654766094 +0000
+@@ -94,7 +94,8 @@
+ set(_xprefix ${_prefix})
+ endif(FORCE_EXTERNAL_STATIC)
+
+- _pkg_check_modules_internal(0 0 ${_prefix} "${_package}")
++ _pkg_check_modules_internal(0 0 0 0 ${_prefix} "${_package}")
++
+ if(${_prefix}_FOUND)
+ cmake_link_flags(${_link_FLAGS} "${${_xprefix}_LDFLAGS}")
+ # If libraries cannot be not found, then that is equivalent to whole