summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMiguel de Val-Borro2020-08-25 06:25:36 -0400
committerMiguel de Val-Borro2020-08-25 06:26:15 -0400
commite88bf051dce2cc622dd16d530e9adb8a2b29a01f (patch)
treeb02e042c4861db13f29cb09e4d483bd5e239b5eb
parent7ae7324a3109139e09445d40a1a1c51b8882a2f5 (diff)
downloadaur-e88bf051dce2cc622dd16d530e9adb8a2b29a01f.tar.gz
patching file bindings/qt_gui/plqt.cpp
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD12
-rw-r--r--plplot.patch12
3 files changed, 24 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6fdb164031f4..4280dd4f27a2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = plplot
pkgdesc = A cross-platform software package for creating scientific plots
pkgver = 5.15.0
- pkgrel = 3
+ pkgrel = 4
url = http://plplot.sourceforge.net/
arch = i686
arch = x86_64
@@ -22,7 +22,9 @@ pkgbase = plplot
options = !libtool
options = !makeflags
source = http://downloads.sourceforge.net/sourceforge/plplot/plplot-5.15.0.tar.gz
+ source = plplot.patch
md5sums = 36aec5bfadc2e207cf8ee39f573c9303
+ md5sums = 16ed4043306ce791e28ef80a80c1fbfd
pkgname = plplot
diff --git a/PKGBUILD b/PKGBUILD
index 5b74e3b86d97..7db14a834363 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# Contributor: Eric Belanger <eric@archlinux.org>
pkgname=plplot
pkgver=5.15.0
-pkgrel=3
+pkgrel=4
pkgdesc="A cross-platform software package for creating scientific plots"
arch=('i686' 'x86_64')
url="http://plplot.sourceforge.net/"
@@ -21,8 +21,14 @@ optdepends=('qhull: calculating convex hulls'
'ttf-freefont: enables use of ttf fonts for some drivers'
'cairo: displays plots and save to different file formats')
options=('!libtool' '!makeflags')
-source=(http://downloads.sourceforge.net/sourceforge/plplot/${pkgname}-${pkgver}.tar.gz)
-md5sums=('36aec5bfadc2e207cf8ee39f573c9303')
+source=(http://downloads.sourceforge.net/sourceforge/plplot/${pkgname}-${pkgver}.tar.gz plplot.patch)
+md5sums=('36aec5bfadc2e207cf8ee39f573c9303'
+ '16ed4043306ce791e28ef80a80c1fbfd')
+
+prepare() {
+ cd "$pkgname-$pkgver"
+ patch --forward --strip=1 --input="${srcdir}/plplot.patch"
+}
build() {
cd ${srcdir}/${pkgname}-${pkgver}
diff --git a/plplot.patch b/plplot.patch
new file mode 100644
index 000000000000..35b4e3fca2c6
--- /dev/null
+++ b/plplot.patch
@@ -0,0 +1,12 @@
+diff --unified --recursive --text plplot-5.15.0.orig/bindings/qt_gui/plqt.cpp plplot-5.15.0.new/bindings/qt_gui/plqt.cpp
+--- plplot-5.15.0.orig/bindings/qt_gui/plqt.cpp 2019-06-01 19:24:33.000000000 -0400
++++ plplot-5.15.0.new/bindings/qt_gui/plqt.cpp 2020-08-25 06:15:42.665298916 -0400
+@@ -22,6 +22,8 @@
+ // 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA
+ //
+
++#include <QPainterPath>
++
+ #include "qt.h"
+
+ // Global variables for Qt driver.