summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoraik22022-03-21 15:22:47 +0800
committeraik22022-03-21 15:22:47 +0800
commitf2b67c60ff4ad654628d338de6b888a1fdd66eff (patch)
treebe3f6c2bcab1ad8c9cc7fa46803d1ac4a7f14dc5
parentce0c899328be621c939fa83b0fc3e45ceda6d076 (diff)
downloadaur-f2b67c60ff4ad654628d338de6b888a1fdd66eff.tar.gz
add desktop entry
-rw-r--r--PKGBUILD6
-rw-r--r--plugdata.desktop10
2 files changed, 15 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 02a325e170ba..0bf5203e3e71 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,7 @@
# Maintainer: aik2 aik2mlj@gmail.com
pkgname='plugdata-git'
+_name='plugdata'
pkgdesc='Plugin wrapper around PureData with a new GUI made with JUCE, allowing patching in DAWs'
pkgver=r521.5658cab
pkgrel=1
@@ -32,6 +33,9 @@ build () {
}
package () {
+ # Desktop entry
+ install -Dm644 "${srcdir}/../${_name}.desktop" "${pkgdir}/usr/share/applications/${_name}.desktop"
+
cd "${srcdir}/PlugData"
# === modified from .github/scripts/package.sh ===
@@ -58,5 +62,5 @@ package () {
find ./Packaged -name '*.lv2' -type d -exec cp -ar {} "${pkgdir}/usr/lib/lv2/" \;
mkdir -p "${pkgdir}/usr/lib/vst3/"
find ./Packaged -name '*.vst3' -type d -exec cp -ar {} "${pkgdir}/usr/lib/vst3/" \;
- install -Dm755 -T Packaged/Standalone/* "${pkgdir}/usr/bin/plugdata"
+ install -Dm755 -T Packaged/Standalone/* "${pkgdir}/usr/bin/${_name}"
}
diff --git a/plugdata.desktop b/plugdata.desktop
new file mode 100644
index 000000000000..bfea61f874fd
--- /dev/null
+++ b/plugdata.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Version=1.0
+Type=Application
+Name=PlugData
+Comment=Pure Data as a plugin, with a new GUI
+Exec=/usr/bin/plugdata
+Icon=pd
+Terminal=false
+StartupNotify=false
+Categories=AudioVideo;Audio;