summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabien LEFEBVRE (d1ceward)2024-05-19 20:47:18 +0200
committerFabien LEFEBVRE (d1ceward)2024-05-19 20:47:18 +0200
commit105e2f19d7df32629f6e4cdac5029074bc268370 (patch)
treef6bb46ffb794fc115ac3e59c8dd83e08739b95ce
parent21bb6e88f84c38bf112379783d4cd50343be7869 (diff)
downloadaur-105e2f19d7df32629f6e4cdac5029074bc268370.tar.gz
upgpkg: plugn 0.15.3-1
upstream release
-rw-r--r--.SRCINFO9
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD25
3 files changed, 24 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e5c800968f5d..f69a7637557c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,12 @@
pkgbase = plugn
pkgdesc = Hook system that lets users extend your application with plugins
- pkgver = 0.13.0
+ pkgver = 0.15.3
pkgrel = 1
url = https://github.com/dokku/plugn
arch = x86_64
license = MIT
- source = https://github.com/dokku/plugn/releases/download/v0.13.0/plugn_0.13.0_linux_amd64.tgz
- source = LICENSE
- sha256sums = 093bc8f6ad6f92519c39ee9e2ccb977ab2825a65b3fc8b0116712d3784ae91be
- sha256sums = b1ac2fed5ac269fb7bbf651a3d37ef5fd56d2c33320e17cb6e23a22a93f5c046
+ makedepends = go
+ source = https://github.com/dokku/plugn/archive/refs/tags/v0.15.3.tar.gz
+ sha256sums = db1ea0c9017fa5444eff0134b45e9dbd25cd8c51ae279c66e7af78e6f11be667
pkgname = plugn
diff --git a/.gitignore b/.gitignore
index f9ecc0a87e76..0afc2fb10964 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,4 @@
/src/
/pkg/
-/*.tgz
+/*.tar.gz
/*.pkg.tar.zst
diff --git a/PKGBUILD b/PKGBUILD
index b8f42691a310..a2360b5ccd1f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,31 @@
# Maintainer: Fabien LEFEBVRE <contact@d1ceward.com>
pkgname=plugn
-pkgver=0.13.0
+pkgver=0.15.3
pkgrel=1
pkgdesc='Hook system that lets users extend your application with plugins'
arch=('x86_64')
url='https://github.com/dokku/plugn'
license=('MIT')
-source=("${url}/releases/download/v${pkgver}/${pkgname}_${pkgver}_linux_amd64.tgz"
- 'LICENSE')
-sha256sums=('093bc8f6ad6f92519c39ee9e2ccb977ab2825a65b3fc8b0116712d3784ae91be'
- 'b1ac2fed5ac269fb7bbf651a3d37ef5fd56d2c33320e17cb6e23a22a93f5c046')
+source=("${url}/archive/refs/tags/v${pkgver}.tar.gz")
+sha256sums=('db1ea0c9017fa5444eff0134b45e9dbd25cd8c51ae279c66e7af78e6f11be667')
+makedepends=('go')
+
+build() {
+ cd "${pkgname}-${pkgver}"
+
+ # Build executable
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export CGO_LDFLAGS="${LDFLAGS}"
+ export GOFLAGS="-asmflags=-trimpath=/src -gcflags=-trimpath=/src"
+ go build -a -ldflags "-s -w -X main.Version=${pkgver}" -o "${pkgname}-build" .
+}
package() {
- install -Dm755 "${pkgname}-amd64" "${pkgdir}/usr/bin/${pkgname}"
+ cd "${pkgname}-${pkgver}"
+
+ install -Dm755 "${pkgname}-build" "${pkgdir}/usr/bin/${pkgname}"
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}