summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKrzysztof (3ED) AS2015-07-02 10:03:49 +0200
committerKrzysztof (3ED) AS2015-07-02 10:03:49 +0200
commit216d7e2d8c76e1563e0898a616f6c1791ec479b0 (patch)
treede555ed0cb10bca8dd504e8394236341e87928a0
downloadaur-216d7e2d8c76e1563e0898a616f6c1791ec479b0.tar.gz
moving files, making space for additional scripts, aur4 and other stuff
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD44
2 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fc71b861cd3b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = pluma-plugins
+ pkgver = 1.8.0
+ pkgrel = 1
+ epoch = 1
+ url = https://github.com/cygwinports/pluma-plugins
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = pluma
+ depends = mate-common
+ source = pluma-plugins-1.8.0.tar.gz::https://github.com/cygwinports/pluma-plugins/archive/1.8.0.tar.gz
+ sha256sums = d27bd9e7aa05d0bd23812d6087646880019f15d26cb94fc3e857c3806f228fe9
+
+pkgname = pluma-plugins
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0df1ba9da752
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Mantainer: 3ED <krzysztof1987 at gmail>
+# Contributor: adlerweb <get on aur>
+
+pkgname=pluma-plugins
+_reponame=cygwinports
+pkgver=1.8.0
+epoch=1
+pkgrel=1
+arch=('i686' 'x86_64')
+url="https://github.com/${_reponame}/${pkgname}"
+license=('GPL')
+depends=('pluma' 'mate-common')
+#makedepends=('autoconf-2.5' 'automake-1.12')
+source=(${pkgname}-${pkgver}.tar.gz::https://github.com/${_reponame}/${pkgname}/archive/${pkgver}.tar.gz)
+sha256sums=('d27bd9e7aa05d0bd23812d6087646880019f15d26cb94fc3e857c3806f228fe9')
+
+build() {
+ cd "$srcdir/${pkgname}-${pkgver}"
+ PYTHON=/usr/bin/python2 ./autogen.sh \
+ --prefix=/usr \
+ --sbindir=/usr/bin \
+ --libexecdir=/usr/lib/${pkgname} \
+ --with-plugins=all \
+ --with-gtk=2.0 \
+ --enable-gtk-doc \
+ --enable-python
+
+ # Who know? Does "make" do it automaticly?
+ local cpucounts="$(cat /sys/devices/system/cpu/online)"
+ cpucounts="${cpucounts#0-}"
+ if [[ $cpucounts =~ ^[0-9]+$ ]]; then
+ # This should make compilation much much faster on amds or
+ # expensive intels (with many cores).
+ make -j $[cpucounts + 1]
+ else
+ # Fallback
+ make
+ fi
+}
+
+package() {
+ cd "$srcdir/${pkgname}-${pkgver}"
+ make DESTDIR="$pkgdir" install
+}