summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKrzysztof (3ED) AS2015-09-21 14:50:57 +0200
committerKrzysztof (3ED) AS2015-09-21 14:50:57 +0200
commitafe08a0a6106c555d193f59bd85064cb49049bfd (patch)
tree71b860e4241f8fcaca8f1ca3126d23d0f80b8c9a
parent216d7e2d8c76e1563e0898a616f6c1791ec479b0 (diff)
downloadaur-afe08a0a6106c555d193f59bd85064cb49049bfd.tar.gz
Option -j should be set in makepkg.conf
-rw-r--r--PKGBUILD13
1 files changed, 2 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0df1ba9da752..24bd1bfe18bc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -25,17 +25,8 @@ build() {
--enable-gtk-doc \
--enable-python
- # Who know? Does "make" do it automaticly?
- local cpucounts="$(cat /sys/devices/system/cpu/online)"
- cpucounts="${cpucounts#0-}"
- if [[ $cpucounts =~ ^[0-9]+$ ]]; then
- # This should make compilation much much faster on amds or
- # expensive intels (with many cores).
- make -j $[cpucounts + 1]
- else
- # Fallback
- make
- fi
+ # For SMP look at MAKEFLAGS="-j8" (where 8 is 8 cpus/cores) in /etc/makepkg.conf
+ make
}
package() {