summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHector Mtz-Seara2015-11-09 15:37:58 +0100
committerHector Mtz-Seara2015-11-09 15:37:58 +0100
commit672cc3a8386a05300a1fdcb4c871781bbd085caa (patch)
treea0078fbdc03badb483e0b61f07504463c01bec26
downloadaur-672cc3a8386a05300a1fdcb4c871781bbd085caa.tar.gz
Initial import: v2.2.0-1
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD32
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4a67ac070290
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = plumed
+ pkgdesc = An open source plugin for free energy calculations in molecular systems which works together with some of the most popular molecular dynamics engines.
+ pkgver = 2.2.0
+ pkgrel = 1
+ url = http://www.plumed-code.org/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = atlas-lapack-base
+ depends = zlib
+ depends = bash
+ optdepends = libmatheval: Calculate a combination of variables using a matheval expression
+ provides = plumed
+ source = https://github.com/plumed/plumed2/archive/v2.2.0.tar.gz
+ sha1sums = 2dbf6d4287ebfce313c6fd4c949ead3c7325543c
+
+pkgname = plumed
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b9bf58036728
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# PKGBUILD template to install Espresso
+# Maintainer: Hector Martinez-Seara Monne <hseara ##[at]## gmail?com>
+
+pkgname=plumed
+pkgver=2.2.0
+pkgrel=1
+pkgdesc="An open source plugin for free energy calculations in molecular systems which works together with some of the most popular molecular dynamics engines."
+url="http://www.plumed-code.org/"
+license=("GPL")
+arch=(i686 x86_64)
+depends=('atlas-lapack-base' 'zlib' 'bash')
+optdepends=('libmatheval: Calculate a combination of variables using a matheval expression')
+makedepends=()
+provides=('plumed')
+#install=$pkgname.install
+source=( https://github.com/plumed/plumed2/archive/v${pkgver}.tar.gz)
+sha1sums=('2dbf6d4287ebfce313c6fd4c949ead3c7325543c')
+#options=(!buildflags)
+
+build() {
+cd ${srcdir}/${pkgname}2-${pkgver}
+
+./configure --prefix=/usr --disable-mpi
+make
+}
+package() {
+cd ${srcdir}/${pkgname}2-${pkgver}
+make DESTDIR=${pkgdir} install
+}
+
+### Please Remember to set the following environment variable ###
+# PLUMED_KERNEL=/usr/lib/libplumedKernel.so"