summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHector Martinez-Seara2019-03-18 11:18:50 +0100
committerHector Martinez-Seara2019-03-18 11:18:50 +0100
commit6963bc5e9638ac38bf1a7d60a12c013b7e719b83 (patch)
tree3510f17e44d90bc20f552b5cf2b4838634e7316b
parentbab004c6b09d42cf61ed80c57fb5dd56628e5a84 (diff)
downloadaur-6963bc5e9638ac38bf1a7d60a12c013b7e719b83.tar.gz
Adding vmd-molfile plugin support
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD14
2 files changed, 15 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6703c20f892d..2e9675da6828 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,16 @@
pkgbase = plumed
pkgdesc = An open source plugin for free energy calculations in molecular systems which works together with some of the most popular molecular dynamics engines.
pkgver = 2.5.0
- pkgrel = 1
- url = http://www.plumed-code.org/
+ pkgrel = 2
+ url = http://www.plumed.org/
arch = i686
arch = x86_64
license = GPL
depends = lapack
depends = zlib
depends = gsl
+ depends = netcdf
+ optdepends = vmd-molfile-plugins: Add capability to read vmd compatible trajectories
provides = plumed
source = https://github.com/plumed/plumed2/releases/download/v2.5.0/plumed-2.5.0.tgz
sha1sums = 0b93fcd39a4e5b1b81e24657438e3831faa53753
diff --git a/PKGBUILD b/PKGBUILD
index 9ab88d9a2d91..448579a0053a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,12 +3,13 @@
pkgname=plumed
pkgver=2.5.0
-pkgrel=1
+pkgrel=2
pkgdesc="An open source plugin for free energy calculations in molecular systems which works together with some of the most popular molecular dynamics engines."
-url="http://www.plumed-code.org/"
+url="http://www.plumed.org/"
license=("GPL")
arch=(i686 x86_64)
-depends=('lapack' 'zlib' 'gsl')
+depends=('lapack' 'zlib' 'gsl' 'netcdf')
+optdepends=('vmd-molfile-plugins: Add capability to read vmd compatible trajectories')
makedepends=()
provides=('plumed')
#install=$pkgname.install
@@ -16,6 +17,13 @@ source=( https://github.com/plumed/plumed2/releases/download/v${pkgver}/plumed-$
sha1sums=('0b93fcd39a4e5b1b81e24657438e3831faa53753')
#options=(!buildflags)
+# Extend support for trajectory analysis to formats undestood by vmd
+if [ -d "/usr/lib/vmd-molfile-plugins" ]; then
+ msg2 "Adding vmd-molfile plugin support"
+ LDFLAGS+=" -L/usr/lib/vmd-molfile-plugins -lnetcdf"
+ CPPFLAGS+=" -I/usr/include/vmd-molfile-plugins"
+fi
+
build() {
cd ${srcdir}/${pkgname}-${pkgver}
./configure --prefix=/usr --disable-mpi