summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpapajoker2015-07-01 00:15:20 +0200
committerpapajoker2015-07-01 00:15:20 +0200
commita0462db58d786c7d15da7a59cbe9c0890d7d198e (patch)
treec18023825f4770291a52ca3de11dd9f30d2153ab
downloadaur-a0462db58d786c7d15da7a59cbe9c0890d7d198e.tar.gz
first commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD28
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..54cdf697c520
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by makepkg 4.2.1
+# Tue Jun 30 16:59:19 UTC 2015
+pkgbase = plus-dm
+ pkgdesc = DM choise at startx
+ pkgver = 0.1.0
+ pkgrel = 0
+ url = https://github.com/papajoker/plus-dm
+ arch = any
+ license = GPL
+ makedepends = git
+ depends = pacman
+ optdepends = kdialog: KDE dialog box
+ optdepends = zenity: GTK dialog box
+ source = plus-dm::git+http://github.com/papajoker/plus-dm#branch=master
+ md5sums = SKIP
+
+pkgname = plus-dm
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6227721f984b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Papajoker <papajoker [at] archlinux [dot] info>
+pkgname=plus-dm
+pkgver=0.1.0
+pkgrel=0
+pkgdesc="DM choise at startx"
+arch=('any')
+url="https://github.com/papajoker/plus-dm"
+license=('GPL')
+groups=()
+depends=('pacman')
+makedepends=('git')
+optdepends=('kdialog: KDE dialog box'
+ 'zenity: GTK dialog box')
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+source=("$pkgname::git+http://github.com/papajoker/plus-dm#branch=master")
+noextract=()
+md5sums=('SKIP')
+
+package() {
+ cd "$srcdir/$pkgname"
+ install -Dm755 ./${pkgname}.sh ${pkgdir}/etc/X11/xinit/xinitrc.d/${pkgname}.sh
+ install -Dm644 ./${pkgname}.model.conf ${pkgdir}/etc/${pkgname}.model.conf
+}