summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSammysHP2022-05-26 12:49:53 +0200
committerSammysHP2022-05-26 12:49:53 +0200
commit870a0e5b49fd3a2ed44dbc3f346bed0923f40799 (patch)
tree35543d0b351cc620a93921ebfb3a0403d1f92429
downloadaur-870a0e5b49fd3a2ed44dbc3f346bed0923f40799.tar.gz
Version 1.0.4
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD46
-rw-r--r--plus42.desktop7
3 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..46c8f95aba3d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = plus42
+ pkgdesc = Advanced scientific programmable calculator, based on Free42
+ pkgver = 1.0.4
+ pkgrel = 1
+ url = https://thomasokken.com/plus42/
+ arch = x86_64
+ license = GPL
+ depends = gtk3
+ source = http://thomasokken.com/plus42/upstream/plus42-upstream-1.0.4.tgz
+ source = plus42.desktop
+ md5sums = 387e9a4866111c79c9572248bf8c39c2
+ md5sums = ba6d9ff8d83e9a244b5da63acbfc018e
+
+pkgname = plus42
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9e782a3c02ac
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Sven Karsten Greiner <sven@sammyshp.de>
+
+pkgname=plus42
+pkgver=1.0.4
+pkgrel=1
+pkgdesc="Advanced scientific programmable calculator, based on Free42"
+arch=('x86_64')
+url="https://thomasokken.com/plus42/"
+license=('GPL')
+depends=('gtk3')
+source=("http://thomasokken.com/plus42/upstream/$pkgname-upstream-$pkgver.tgz"
+ "plus42.desktop")
+md5sums=('387e9a4866111c79c9572248bf8c39c2'
+ 'ba6d9ff8d83e9a244b5da63acbfc018e')
+
+build() {
+ cd "$srcdir/$pkgname-upstream-$pkgver/gtk"
+
+ # build both bin and dec version
+ make cleaner
+ make
+ make clean
+ make BCD_MATH=1
+}
+
+package() {
+ cd "$srcdir/$pkgname-upstream-$pkgver/gtk"
+
+ install -Dm755 plus42bin "$pkgdir/usr/bin/plus42bin"
+ install -Dm755 plus42dec "$pkgdir/usr/bin/plus42dec"
+
+ install -Dm644 README "$pkgdir/usr/share/doc/$pkgname/README_GTK"
+ install -Dm644 ../README "$pkgdir/usr/share/doc/$pkgname/README"
+
+ install -Dm644 icon-48x48.xpm "$pkgdir/usr/share/icons/hicolor/48x48/apps/plus42.xpm"
+ install -Dm644 icon-128x128.xpm "$pkgdir/usr/share/icons/hicolor/128x128/apps/plus42.xpm"
+
+ ln -s /usr/bin/plus42dec "$pkgdir/usr/bin/plus42"
+
+ cd ../skins
+ for x in Plus42.* README.txt; do
+ install -Dm644 $x "$pkgdir/usr/share/$pkgname/skins/$x"
+ done
+
+ install -Dm644 "$srcdir/plus42.desktop" "$pkgdir/usr/share/applications/com.thomasokken.plus42.desktop"
+}
diff --git a/plus42.desktop b/plus42.desktop
new file mode 100644
index 000000000000..f91ba31d9c20
--- /dev/null
+++ b/plus42.desktop
@@ -0,0 +1,7 @@
+[Desktop Entry]
+Name=Plus42
+Exec=/usr/bin/plus42
+Icon=plus42
+Terminal=false
+Type=Application
+Categories=Utility;Calculator;