summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNihilistzsche2023-02-03 02:32:40 -0800
committerNihilistzsche2023-02-03 02:32:40 -0800
commit48262c8a66b7c606409c1b11f6951ffe8cff39e1 (patch)
tree506c4e85bea243014823ad83ce3788477b0c4847
downloadaur-48262c8a66b7c606409c1b11f6951ffe8cff39e1.tar.gz
First version.
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD25
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5969f15ab73c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = plymouth-i_use_arch_btw-git
+ pkgdesc = Plymouth theme "i_use_arch_btw"
+ pkgver = r5.5762e93
+ pkgrel = 1
+ url = https://github.com/SimoriccITA/plymouth-i_use_arch_btw
+ arch = any
+ license = GPL3
+ depends = plymouth
+ provides = plymouth-i_use_arch_btw-git
+ conflicts = plymouth-i_use_arch_btw-git
+ source = plymouth-i_use_arch_btw::git+https://github.com/SimoriccITA/plymouth-i_use_arch_btw.git
+ sha256sums = SKIP
+
+pkgname = plymouth-i_use_arch_btw-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bd5432cc1d3b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Michael Tindal <nihilistzsche@gmail.com>
+pkgname=plymouth-i_use_arch_btw-git
+_pkgname=plymouth-i_use_arch_btw
+pkgdesc='Plymouth theme "i_use_arch_btw"'
+arch=('any')
+url='https://github.com/SimoriccITA/plymouth-i_use_arch_btw'
+depends=('plymouth')
+license=('GPL3')
+provides=("${_pkgname}-git")
+conflicts=("${_pkgname}-git")
+source=("$_pkgname::git+${url}.git")
+pkgver=r5.5762e93
+pkgrel=1
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${_pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}"
+ mkdir -p "${pkgdir}/usr/share/plymouth/themes"
+ cp -r i_use_arch_btw "${pkgdir}/usr/share/plymouth/themes"
+}