summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexandre Bouvier2018-06-12 15:28:50 +0200
committerAlexandre Bouvier2018-06-12 15:28:50 +0200
commit1a23bbc94ba273d954508c150e7b9813ba711afb (patch)
tree48a356148780ce378e5f6a3ca71b8000535fea1f
parent08a5fecffff9dc69537e71fdcaaff7a6d1efdb03 (diff)
downloadaur-1a23bbc94ba273d954508c150e7b9813ba711afb.tar.gz
5.13.0
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD8
2 files changed, 10 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 985568693114..e3d2d08e1ad7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = plymouth-kcm
pkgdesc = KCM to manage the Plymouth (Boot) theme
- pkgver = 5.12.5
+ pkgver = 5.13.0
pkgrel = 1
url = https://cgit.kde.org/plymouth-kcm.git/
arch = x86_64
@@ -10,10 +10,11 @@ pkgbase = plymouth-kcm
depends = plymouth
depends = knewstuff
depends = kdeclarative
- source = https://download.kde.org/stable/plasma/5.12.5/plymouth-kcm-5.12.5.tar.xz
- source = https://download.kde.org/stable/plasma/5.12.5/plymouth-kcm-5.12.5.tar.xz.sig
+ source = https://download.kde.org/stable/plasma/5.13.0/plymouth-kcm-5.13.0.tar.xz
+ source = https://download.kde.org/stable/plasma/5.13.0/plymouth-kcm-5.13.0.tar.xz.sig
validpgpkeys = 2D1D5B0588357787DE9EE225EC94D18F7F05997E
- sha256sums = 29824b1252ce691bd247cc91a49a5def2a86f47443a01edb2e6f9d26d25962bb
+ validpgpkeys = 0AAC775BB6437A8D9AF7A3ACFE0784117FBCE11D
+ sha256sums = 26a2098d9ace2e63cfe2ab5fe49c7ba8471af0293e134deece3296763d56efc8
sha256sums = SKIP
pkgname = plymouth-kcm
diff --git a/PKGBUILD b/PKGBUILD
index 06a846faac9c..22a5b7c814b5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Maintainer: Alexandre Bouvier <contact@amb.tf>
# Contributor: Daniel Cohen <dan@supercore.co.uk>
pkgname=plymouth-kcm
-pkgver=5.12.5
+pkgver=5.13.0
pkgrel=1
pkgdesc="KCM to manage the Plymouth (Boot) theme"
arch=('x86_64')
@@ -12,9 +12,10 @@ license=('GPL')
depends=('plymouth' 'knewstuff' 'kdeclarative')
makedepends=('extra-cmake-modules' 'qt5-tools')
source=("https://download.kde.org/stable/plasma/$pkgver/$pkgname-$pkgver.tar.xz"{,.sig})
-sha256sums=('29824b1252ce691bd247cc91a49a5def2a86f47443a01edb2e6f9d26d25962bb'
+sha256sums=('26a2098d9ace2e63cfe2ab5fe49c7ba8471af0293e134deece3296763d56efc8'
'SKIP')
-validpgpkeys=('2D1D5B0588357787DE9EE225EC94D18F7F05997E') # Jonathan Riddell
+validpgpkeys=('2D1D5B0588357787DE9EE225EC94D18F7F05997E' # Jonathan Riddell
+ '0AAC775BB6437A8D9AF7A3ACFE0784117FBCE11D') # Bhushan Shah
prepare() {
mkdir -p build
@@ -24,6 +25,7 @@ build() {
cd build
cmake ../"$pkgname-$pkgver" \
-DCMAKE_INSTALL_PREFIX="$(qtpaths --install-prefix)" \
+ -DCMAKE_INSTALL_LIBDIR=lib \
-DCMAKE_BUILD_TYPE=Release \
-DBUILD_TESTING=OFF
make