summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavidyz2023-11-11 04:32:16 +0000
committerDavidyz2023-11-11 04:32:16 +0000
commit5888ad45cb16593c8607ed7a30151c31907a4cbf (patch)
treee4a19cfe128cb6f76bdbbe7bf8fb59a7b669ee22
downloadaur-5888ad45cb16593c8607ed7a30151c31907a4cbf.tar.gz
Initial commit that adds the package.
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD18
-rw-r--r--plymouth-theme-550w.install12
3 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..18e3222842b8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = plymouth-theme-550w
+ pkgdesc = A Plymouth theme for the 550W from movie The Wandering Earth.
+ pkgver = 0.1
+ pkgrel = 1
+ install = plymouth-theme-550w.install
+ arch = any
+ license = GPL
+ depends = plymouth
+ source = git+https://github.com/Davidyz/plymouth-theme-550w.git
+ md5sums = SKIP
+
+pkgname = plymouth-theme-550w
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a1dd12b84608
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: Davidyz (hzjlyz@gmail.com)
+pkgname=plymouth-theme-550w
+pkgver=0.1
+pkgrel=1
+pkgdesc="A Plymouth theme for the 550W from movie The Wandering Earth."
+arch=('any')
+url=""
+license=('GPL')
+depends=(plymouth)
+source=("git+https://github.com/Davidyz/plymouth-theme-550w.git")
+md5sums=("SKIP") #generate with 'makepkg -g'
+install=plymouth-theme-550w.install
+
+package() {
+ cd "$pkgname"
+ mkdir -p $pkgdir/usr/share/plymouth/themes/550w/
+ install -Dm755 assets/* $pkgdir/usr/share/plymouth/themes/550w
+}
diff --git a/plymouth-theme-550w.install b/plymouth-theme-550w.install
new file mode 100644
index 000000000000..fb6a82e43e55
--- /dev/null
+++ b/plymouth-theme-550w.install
@@ -0,0 +1,12 @@
+post_install(){
+ cat << EOF
+
+ ==> To activate, Run:
+ ==> sudo plymouth-set-default-theme -R 550w
+
+EOF
+}
+
+post_upgrade(){
+ post_install
+}