summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNenad Stojanovikj2018-03-09 00:32:50 +0100
committerNenad Stojanovikj2018-03-09 00:34:15 +0100
commit12ac293a87ee322625299ba91569026516940e25 (patch)
tree4bf2a2c95d4497e4929f5fb93018cd30b11a0611
downloadaur-12ac293a87ee322625299ba91569026516940e25.tar.gz
Add v0.1
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD28
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4af6b3abf140
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = plymouth-theme-arch-beat
+ pkgdesc = Plymouth theme with pulsating Arch Linux logo.
+ pkgver = 0.1
+ pkgrel = 1
+ url = https://github.com/nenadstojanovikj/arch-beat/
+ arch = any
+ license = MIT
+ makedepends = git
+ depends = plymouth
+ source = https://github.com/nenadstojanovikj/arch-beat/archive/v0.1.tar.gz
+ sha256sums = SKIP
+
+pkgname = plymouth-theme-arch-beat
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..646a2cac6feb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Nenad Stojanovikj <nekk1@live.com>
+
+pkgname=plymouth-theme-arch-beat
+pkgver='0.1'
+pkgrel=1
+pkgdesc='Plymouth theme with pulsating Arch Linux logo.'
+arch=('any')
+url="https://github.com/nenadstojanovikj/arch-beat/"
+license=('MIT')
+depends=('plymouth')
+makedepends=('git')
+source=("https://github.com/nenadstojanovikj/arch-beat/archive/v${pkgver}.tar.gz")
+sha256sums=('SKIP')
+
+package() {
+ cd "arch-beat-${pkgver}"
+
+ _themedir="$pkgdir/usr/share/plymouth/themes/arch-beat"
+
+ for N in *.png arch-beat.plymouth arch-beat.script; do
+ install -Dm644 $N "${_themedir}/$N"
+ done
+
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm644 README.md "$pkgdir/usr/share/doc/$pkgname/README.md"
+}
+
+# vim:set ts=2 sw=2 et: