summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJiri Tyr2017-07-01 02:28:58 +0100
committerJiri Tyr2017-07-01 02:29:30 +0100
commit0562f73762f0044c0caf14124977fdb8f5e45288 (patch)
treebe9d86033fdc737a6aca84ca33d79835ccfc47e4
downloadaur-0562f73762f0044c0caf14124977fdb8f5e45288.tar.gz
Initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD30
-rw-r--r--plymouth-theme-arch-breeze-git.install9
4 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c4d718c35327
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+# Generated by mksrcinfo v8
+# Sat Jul 1 01:29:19 UTC 2017
+pkgbase = plymouth-theme-arch-breeze-git
+ pkgdesc = Plymouth theme for Arch Linux inspired by KDE Breeze.
+ pkgver = r2.5061c0e
+ pkgrel = 1
+ url = https://github.com/plymouth-theme-arch-breeze/
+ install = plymouth-theme-arch-breeze-git.install
+ arch = x86_64
+ arch = i686
+ arch = arm
+ arch = armv6h
+ arch = armv7h
+ license = MIT
+ makedepends = git
+ depends = plymouth
+ source = https://github.com/jtyr/plymouth-theme-arch-breeze/archive/master.tar.gz
+ sha256sums = SKIP
+
+pkgname = plymouth-theme-arch-breeze-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..a5a41c94f7e4
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+master.tar.gz
+plymouth-theme-arch-breeze-git-*
+pkg
+src
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1588128e0ec2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Jiri Tyr <jiri.tyr@gmail.com>
+
+_pkgname=plymouth-theme-arch-breeze
+pkgname="${_pkgname}-git"
+pkgver=r2.5061c0e
+pkgrel=1
+pkgdesc='Plymouth theme for Arch Linux inspired by KDE Breeze.'
+arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h')
+url="https://github.com/${_pkgname}/"
+license=('MIT')
+install="${pkgname}.install"
+depends=('plymouth')
+makedepends=('git')
+source=("https://github.com/jtyr/${_pkgname}/archive/master.tar.gz")
+sha256sums=('SKIP')
+
+package() {
+ cd "${_pkgname}-master"
+
+ _themedir="$pkgdir/usr/share/plymouth/themes/arch-breeze"
+
+ for N in *.png arch-breeze.plymouth script; do
+ install -Dm644 $N "${_themedir}/$N"
+ done
+
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm644 README.md "$pkgdir/usr/share/doc/$pkgname/README.md"
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/plymouth-theme-arch-breeze-git.install b/plymouth-theme-arch-breeze-git.install
new file mode 100644
index 000000000000..2857def1db01
--- /dev/null
+++ b/plymouth-theme-arch-breeze-git.install
@@ -0,0 +1,9 @@
+_themedir="/usr/share/plymouth/themes/arch-breeze"
+
+post_install() {
+ [ -e "${_themedir}/logo.png" ] || ln -s ${_themedir}/logo{_full_blue,}.png
+}
+
+pre_remove() {
+ rm -f ${_themedir}/logo.png
+}