summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJorge Barroso2015-06-15 21:26:35 +0200
committerJorge Barroso2015-06-15 21:26:35 +0200
commit4c37c0d2969dff0140cace8b4ec7c59eff0e8f79 (patch)
treee7e7d057c74194ffe31f1bdb187e4c5c15e65eef
downloadaur-plymouth-theme-asphyxia-git.tar.gz
Initial import
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD36
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..763e2cba57f4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = plymouth-theme-asphyxia-git
+ pkgdesc = Plymouth theme featuring the famous asphyxia picture from starweaver
+ pkgver = 20120923
+ pkgrel = 1
+ url = http://www.laplanche-melv.in
+ arch = any
+ license = GPL
+ makedepends = git
+ depends = plymouth
+ options = !strip
+
+pkgname = plymouth-theme-asphyxia-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9639fe6f01be
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Melvin Laplanche <melvin.laplanche+pkgbuild[at]gmail[dot]com>
+
+pkgname='plymouth-theme-asphyxia-git'
+pkgver=20120923
+pkgrel=1
+pkgdesc='Plymouth theme featuring the famous asphyxia picture from starweaver'
+arch=('any')
+url='http://www.laplanche-melv.in'
+license=('GPL')
+depends=('plymouth')
+makedepends=('git')
+options=(!strip)
+
+_gitroot="git://github.com/Nivl/plymouth-theme-asphyxia.git"
+_gitname="plymouth-theme-asphyxia"
+
+build() {
+ cd "$srcdir"
+ msg "Connecting to GIT server...."
+
+ if [ -d $_gitname ] ; then
+ cd $_gitname && git pull origin
+ msg "The local files are updated."
+ else
+ git clone $_gitroot $_gitname
+ fi
+
+ msg "GIT checkout done or server timeout"
+}
+
+
+package() {
+ cd "${srcdir}/${_gitname}/asphyxia"
+ install -m755 -d "${pkgdir}/usr/share/plymouth/themes/asphyxia"
+ install -m644 -t "${pkgdir}/usr/share/plymouth/themes/asphyxia" *
+}