summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOle Martin Ruud2018-07-11 23:10:49 +0200
committerOle Martin Ruud2018-07-11 23:51:05 +0200
commit4e8ddcf17bb63df31ee7f5de32742ff3bc1eea33 (patch)
tree6ea8e640b8102fc54b8c06ee94423f176379e4c6
downloadaur-4e8ddcf17bb63df31ee7f5de32742ff3bc1eea33.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD29
-rw-r--r--plymouth-theme-simple-image.install8
4 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8b440a66c901
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = plymouth-theme-simple-image
+ pkgdesc = A Plymouth theme which simply displays an image
+ pkgver = 0.1
+ pkgrel = 1
+ url = https://github.com/barskern/plymouth-theme-simple-image/
+ install = plymouth-theme-simple-image.install
+ arch = any
+ license = custom:BSD3-Clause
+ makedepends = git
+ depends = plymouth
+ source = plymouth-theme-simple-image::git+https://github.com/barskern/plymouth-theme-simple-image.git
+ sha256sums = SKIP
+
+pkgname = plymouth-theme-simple-image-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..91e9cb80e4de
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg/
+src/
+plymouth-theme-simple-image
+*.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4ad82a549320
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Ole Martin Ruud <barskern@outlook.com>
+
+_themename=simple-image
+_pkgname="plymouth-theme-${_themename}"
+pkgname="${_pkgname}-git"
+pkgbase="${_pkgname}"
+pkgver='0.1'
+pkgrel=1
+pkgdesc='A Plymouth theme which simply displays an image'
+arch=('any')
+license=('custom:BSD3-Clause')
+url="https://github.com/barskern/${_pkgname}/"
+depends=('plymouth')
+makedepends=('git')
+source=($_pkgname::"git+https://github.com/barskern/${_pkgname}.git")
+sha256sums=('SKIP')
+install="plymouth-theme-simple-image.install"
+
+package() {
+ cd $_pkgname
+
+ _themedir="$pkgdir/usr/share/plymouth/themes/${_themename}"
+
+ for file in img.png "${_themename}.plymouth" "${_themename}.script"; do
+ install -Dm644 $file "${_themedir}/$file"
+ done
+
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
diff --git a/plymouth-theme-simple-image.install b/plymouth-theme-simple-image.install
new file mode 100644
index 000000000000..11bbd03a685b
--- /dev/null
+++ b/plymouth-theme-simple-image.install
@@ -0,0 +1,8 @@
+post_install() {
+ echo "###############################################"
+ echo ""
+ echo -e "\tTo install the theme run:"
+ echo -e "\tsudo plymouth-set-default-theme -R simple-image"
+ echo ""
+ echo "###############################################"
+}