summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrian Freund2020-03-28 19:59:31 +0100
committerAdrian Freund2020-03-28 20:03:17 +0100
commitabdaebbe1f2745f714558f851a77a8db8425441a (patch)
tree76c70ecc06580cf2fbc36a851b838897fd4f6d4d
downloadaur-abdaebbe1f2745f714558f851a77a8db8425441a.tar.gz
Initial commit
-rw-r--r--.SRCINFO51
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD46
3 files changed, 101 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..14a1210e94cd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,51 @@
+pkgbase = plymouth-themes-adi1090x-pack1
+ pkgdesc = The plymouth theme collection by adi1090x
+ pkgver = 1
+ pkgrel = 1
+ url = https://github.com/adi1090x/plymouth-themes
+ arch = any
+ license = GPL
+ depends = plymouth
+ source = git+https://github.com/adi1090x/plymouth-themes.git
+ md5sums = SKIP
+
+pkgname = plymouth-theme-abstract-ring
+
+pkgname = plymouth-theme-abstract-ring-alt
+
+pkgname = plymouth-theme-alienware
+
+pkgname = plymouth-theme-angular
+
+pkgname = plymouth-theme-angular-alt
+
+pkgname = plymouth-theme-black-hud
+
+pkgname = plymouth-theme-blockchain
+
+pkgname = plymouth-theme-circle
+
+pkgname = plymouth-theme-circle-alt
+
+pkgname = plymouth-theme-circle-flow
+
+pkgname = plymouth-theme-circle-hud
+
+pkgname = plymouth-theme-circuit
+
+pkgname = plymouth-theme-colorful
+
+pkgname = plymouth-theme-colorful-loop
+
+pkgname = plymouth-theme-colorful-sliced
+
+pkgname = plymouth-theme-connect
+
+pkgname = plymouth-theme-cross-hud
+
+pkgname = plymouth-theme-cubes
+
+pkgname = plymouth-theme-cuts
+
+pkgname = plymouth-theme-cuts-alt
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e4f9ba3007cf
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.SRCINFO
+!PKGBUILD
+!.gitignore
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2226f328e3ef
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+#Maintainer: Adrian Freund <adrian@freund.io>
+
+pkgbase=plymouth-themes-adi1090x-pack1
+_themenames=('abstract_ring'
+ 'abstract_ring_alt'
+ 'alienware'
+ 'angular'
+ 'angular_alt'
+ 'black_hud'
+ 'blockchain'
+ 'circle'
+ 'circle_alt'
+ 'circle_flow'
+ 'circle_hud'
+ 'circuit'
+ 'colorful'
+ 'colorful_loop'
+ 'colorful_sliced'
+ 'connect'
+ 'cross_hud'
+ 'cubes'
+ 'cuts'
+ 'cuts_alt')
+pkgname=() #initialized by loop at the bottom
+pkgver=1
+pkgrel=1
+pkgdesc="The plymouth theme collection by adi1090x"
+arch=('any')
+url="https://github.com/adi1090x/plymouth-themes"
+license=('GPL')
+depends=('plymouth')
+
+source=("git+https://github.com/adi1090x/plymouth-themes.git")
+md5sums=('SKIP')
+
+for themename in ${_themenames[*]}
+do
+ pkgname+=("plymouth-theme-${themename//_/-}")
+ eval "
+package_plymouth-theme-${themename//_/-}() {
+ cd \$srcdir/plymouth-themes/pack_1/$themename
+ mkdir -p \$pkgdir/usr/share/plymouth/themes/$themename
+ find . -type f -exec install -Dm644 \"{}\" \"\${pkgdir}\"/usr/share/plymouth/themes/$themename \\;
+}
+"
+done