summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrian Freund2020-03-28 21:34:23 +0100
committerAdrian Freund2020-03-28 21:34:23 +0100
commit1b97ec10846572ea4d899ab99d2753a997c3bdd3 (patch)
treeccec5c7bbed9a7cfd9280e386172047ee751c32f
parentfb7a6a9c8f5ad81e0638551286a6cb0a48860700 (diff)
downloadaur-1b97ec10846572ea4d899ab99d2753a997c3bdd3.tar.gz
Converted to proper git package
-rw-r--r--.SRCINFO46
-rw-r--r--PKGBUILD15
2 files changed, 33 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8fe2a2d758ba..96aafe1b84e7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
-pkgbase = plymouth-themes-adi1090x-pack2
+pkgbase = plymouth-themes-adi1090x-pack2-git
pkgdesc = The plymouth theme collection by adi1090x
- pkgver = 1
- pkgrel = 2
+ pkgver = r24.bb390bd
+ pkgrel = 1
url = https://github.com/adi1090x/plymouth-themes
arch = any
license = GPL
@@ -9,43 +9,43 @@ pkgbase = plymouth-themes-adi1090x-pack2
source = git+https://github.com/adi1090x/plymouth-themes.git
md5sums = SKIP
-pkgname = plymouth-theme-cyanide
+pkgname = plymouth-theme-cyanide-git
-pkgname = plymouth-theme-cybernetic
+pkgname = plymouth-theme-cybernetic-git
-pkgname = plymouth-theme-dark-planet
+pkgname = plymouth-theme-dark-planet-git
-pkgname = plymouth-theme-darth-vader
+pkgname = plymouth-theme-darth-vader-git
-pkgname = plymouth-theme-deus-ex
+pkgname = plymouth-theme-deus-ex-git
-pkgname = plymouth-theme-dna
+pkgname = plymouth-theme-dna-git
-pkgname = plymouth-theme-double
+pkgname = plymouth-theme-double-git
-pkgname = plymouth-theme-dragon
+pkgname = plymouth-theme-dragon-git
-pkgname = plymouth-theme-flame
+pkgname = plymouth-theme-flame-git
-pkgname = plymouth-theme-glitch
+pkgname = plymouth-theme-glitch-git
-pkgname = plymouth-theme-glow
+pkgname = plymouth-theme-glow-git
-pkgname = plymouth-theme-green-blocks
+pkgname = plymouth-theme-green-blocks-git
-pkgname = plymouth-theme-green-loader
+pkgname = plymouth-theme-green-loader-git
-pkgname = plymouth-theme-hexagon
+pkgname = plymouth-theme-hexagon-git
-pkgname = plymouth-theme-hexagon-2
+pkgname = plymouth-theme-hexagon-2-git
-pkgname = plymouth-theme-hexagon-alt
+pkgname = plymouth-theme-hexagon-alt-git
-pkgname = plymouth-theme-hexagon-dots
+pkgname = plymouth-theme-hexagon-dots-git
-pkgname = plymouth-theme-hexagon-dots-alt
+pkgname = plymouth-theme-hexagon-dots-alt-git
-pkgname = plymouth-theme-hexagon-hud
+pkgname = plymouth-theme-hexagon-hud-git
-pkgname = plymouth-theme-hexagon-red
+pkgname = plymouth-theme-hexagon-red-git
diff --git a/PKGBUILD b/PKGBUILD
index df7d34c2c534..2e008994fe27 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
#Maintainer: Adrian Freund <adrian@freund.io>
-pkgbase=plymouth-themes-adi1090x-pack2
+pkgbase=plymouth-themes-adi1090x-pack2-git
_themenames=('cyanide'
'cybernetic'
'dark_planet'
@@ -23,8 +23,8 @@ _themenames=('cyanide'
'hexagon_red')
pkgname=() #initialized by loop at the bottom
-pkgver=1
-pkgrel=2
+pkgver=r24.bb390bd
+pkgrel=1
pkgdesc="The plymouth theme collection by adi1090x"
arch=('any')
url="https://github.com/adi1090x/plymouth-themes"
@@ -34,11 +34,16 @@ depends=('plymouth')
source=("git+https://github.com/adi1090x/plymouth-themes.git")
md5sums=('SKIP')
+pkgver() {
+ cd "plymouth-themes"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
for themename in ${_themenames[*]}
do
- pkgname+=("plymouth-theme-${themename//_/-}")
+ pkgname+=("plymouth-theme-${themename//_/-}-git")
eval "
-package_plymouth-theme-${themename//_/-}() {
+package_plymouth-theme-${themename//_/-}-git() {
cd \$srcdir/plymouth-themes/pack_2/$themename
mkdir -p \$pkgdir/usr/share/plymouth/themes/$themename
find . -type f -exec install -Dm644 \"{}\" \"\${pkgdir}\"/usr/share/plymouth/themes/$themename\"{}\" \\;