summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrian Freund2020-03-28 19:59:31 +0100
committerAdrian Freund2020-03-28 20:11:00 +0100
commita2dd95fc0eb587132e9a8aa087de1240391d1159 (patch)
tree1ace518cfe26e97c2dcb41e8c7be9417c330fc05
downloadaur-a2dd95fc0eb587132e9a8aa087de1240391d1159.tar.gz
Initial commit
-rw-r--r--.SRCINFO51
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD47
3 files changed, 102 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b831f9373729
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,51 @@
+pkgbase = plymouth-themes-adi1090x-pack2
+ pkgdesc = The plymouth theme collection by adi1090x
+ pkgver = 1
+ pkgrel = 1
+ url = https://github.com/adi1090x/plymouth-themes
+ arch = any
+ license = GPL
+ depends = plymouth
+ source = git+https://github.com/adi1090x/plymouth-themes.git
+ md5sums = SKIP
+
+pkgname = plymouth-theme-cyanide
+
+pkgname = plymouth-theme-cybernetic
+
+pkgname = plymouth-theme-dark-planet
+
+pkgname = plymouth-theme-darth-vader
+
+pkgname = plymouth-theme-deus-ex
+
+pkgname = plymouth-theme-dna
+
+pkgname = plymouth-theme-double
+
+pkgname = plymouth-theme-dragon
+
+pkgname = plymouth-theme-flame
+
+pkgname = plymouth-theme-glitch
+
+pkgname = plymouth-theme-glow
+
+pkgname = plymouth-theme-green-blocks
+
+pkgname = plymouth-theme-green-loader
+
+pkgname = plymouth-theme-hexagon
+
+pkgname = plymouth-theme-hexagon-2
+
+pkgname = plymouth-theme-hexagon-alt
+
+pkgname = plymouth-theme-hexagon-dots
+
+pkgname = plymouth-theme-hexagon-dots-alt
+
+pkgname = plymouth-theme-hexagon-hud
+
+pkgname = plymouth-theme-hexagon-red
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e4f9ba3007cf
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.SRCINFO
+!PKGBUILD
+!.gitignore
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..149cd81e7968
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+#Maintainer: Adrian Freund <adrian@freund.io>
+
+pkgbase=plymouth-themes-adi1090x-pack2
+_themenames=('cyanide'
+'cybernetic'
+'dark_planet'
+'darth_vader'
+'deus_ex'
+'dna'
+'double'
+'dragon'
+'flame'
+'glitch'
+'glow'
+'green_blocks'
+'green_loader'
+'hexagon'
+'hexagon_2'
+'hexagon_alt'
+'hexagon_dots'
+'hexagon_dots_alt'
+'hexagon_hud'
+'hexagon_red')
+
+pkgname=() #initialized by loop at the bottom
+pkgver=1
+pkgrel=1
+pkgdesc="The plymouth theme collection by adi1090x"
+arch=('any')
+url="https://github.com/adi1090x/plymouth-themes"
+license=('GPL')
+depends=('plymouth')
+
+source=("git+https://github.com/adi1090x/plymouth-themes.git")
+md5sums=('SKIP')
+
+for themename in ${_themenames[*]}
+do
+ pkgname+=("plymouth-theme-${themename//_/-}")
+ eval "
+package_plymouth-theme-${themename//_/-}() {
+ cd \$srcdir/plymouth-themes/pack_2/$themename
+ mkdir -p \$pkgdir/usr/share/plymouth/themes/$themename
+ find . -type f -exec install -Dm644 \"{}\" \"\${pkgdir}\"/usr/share/plymouth/themes/$themename \\;
+}
+"
+done