summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrian Freund2020-04-04 16:47:20 +0200
committerAdrian Freund2020-04-04 16:47:20 +0200
commit1dc6c683798abf7e57aca7cbf4966bde24c7353a (patch)
tree85bc0d14e89110ae34b7f02e3c1b064c4860f7f9
downloadaur-1dc6c683798abf7e57aca7cbf4966bde24c7353a.tar.gz
Initial commit
-rw-r--r--.SRCINFO51
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD52
3 files changed, 107 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c769982eb69b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,51 @@
+pkgbase = plymouth-themes-adi1090x-pack3-git
+ pkgdesc = The plymouth theme collection by adi1090x
+ pkgver = r28.32a0d92
+ pkgrel = 1
+ url = https://github.com/adi1090x/plymouth-themes
+ arch = any
+ license = GPL
+ depends = plymouth
+ source = git+https://github.com/adi1090x/plymouth-themes.git
+ md5sums = SKIP
+
+pkgname = plymouth-theme-hexa-retro-git
+
+pkgname = plymouth-theme-hud-git
+
+pkgname = plymouth-theme-hud-2-git
+
+pkgname = plymouth-theme-hud-3-git
+
+pkgname = plymouth-theme-hud-space-git
+
+pkgname = plymouth-theme-ibm-git
+
+pkgname = plymouth-theme-infinite-seal-git
+
+pkgname = plymouth-theme-ironman-git
+
+pkgname = plymouth-theme-liquid-git
+
+pkgname = plymouth-theme-loader-git
+
+pkgname = plymouth-theme-loader-2-git
+
+pkgname = plymouth-theme-loader-alt-git
+
+pkgname = plymouth-theme-lone-git
+
+pkgname = plymouth-theme-metal-ball-git
+
+pkgname = plymouth-theme-motion-git
+
+pkgname = plymouth-theme-optimus-git
+
+pkgname = plymouth-theme-owl-git
+
+pkgname = plymouth-theme-pie-git
+
+pkgname = plymouth-theme-pixels-git
+
+pkgname = plymouth-theme-polaroid-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e4f9ba3007cf
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.SRCINFO
+!PKGBUILD
+!.gitignore
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5bd3682cd92a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,52 @@
+#Maintainer: Adrian Freund <adrian@freund.io>
+
+pkgbase=plymouth-themes-adi1090x-pack3-git
+_themenames=('hexa_retro'
+'hud'
+'hud_2'
+'hud_3'
+'hud_space'
+'ibm'
+'infinite_seal'
+'ironman'
+'liquid'
+'loader'
+'loader_2'
+'loader_alt'
+'lone'
+'metal_ball'
+'motion'
+'optimus'
+'owl'
+'pie'
+'pixels'
+'polaroid')
+
+pkgname=() #initialized by loop at the bottom
+pkgver=r28.32a0d92
+pkgrel=1
+pkgdesc="The plymouth theme collection by adi1090x"
+arch=('any')
+url="https://github.com/adi1090x/plymouth-themes"
+license=('GPL')
+depends=('plymouth')
+
+source=("git+https://github.com/adi1090x/plymouth-themes.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "plymouth-themes"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+for themename in ${_themenames[*]}
+do
+ pkgname+=("plymouth-theme-${themename//_/-}-git")
+ eval "
+package_plymouth-theme-${themename//_/-}-git() {
+ cd \$srcdir/plymouth-themes/pack_3/$themename
+ mkdir -p \$pkgdir/usr/share/plymouth/themes/$themename
+ find . -type f -exec install -Dm644 \"{}\" \"\${pkgdir}\"/usr/share/plymouth/themes/$themename/\"{}\" \\;
+}
+"
+done