summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrian Freund2020-04-04 16:53:44 +0200
committerAdrian Freund2020-04-04 16:53:44 +0200
commit4eb72916c32325b0d152a4851d7e9fadfc49f9ff (patch)
tree99b149f2a25a2b4824eebd2934b07a43d4582019
downloadaur-plymouth-themes-adi1090x-pack4-git.tar.gz
Initial commit
-rw-r--r--.SRCINFO51
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD52
3 files changed, 107 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c7112a441b4f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,51 @@
+pkgbase = plymouth-themes-adi1090x-pack4-git
+ pkgdesc = The plymouth theme collection by adi1090x
+ pkgver = r28.32a0d92
+ pkgrel = 1
+ url = https://github.com/adi1090x/plymouth-themes
+ arch = any
+ license = GPL
+ depends = plymouth
+ source = git+https://github.com/adi1090x/plymouth-themes.git
+ md5sums = SKIP
+
+pkgname = plymouth-theme-red-loader-git
+
+pkgname = plymouth-theme-rings-git
+
+pkgname = plymouth-theme-rings-2-git
+
+pkgname = plymouth-theme-rog-git
+
+pkgname = plymouth-theme-rog-2-git
+
+pkgname = plymouth-theme-seal-git
+
+pkgname = plymouth-theme-seal-2-git
+
+pkgname = plymouth-theme-seal-3-git
+
+pkgname = plymouth-theme-sliced-git
+
+pkgname = plymouth-theme-sphere-git
+
+pkgname = plymouth-theme-spin-git
+
+pkgname = plymouth-theme-spinner-alt-git
+
+pkgname = plymouth-theme-splash-git
+
+pkgname = plymouth-theme-square-git
+
+pkgname = plymouth-theme-square-hud-git
+
+pkgname = plymouth-theme-target-git
+
+pkgname = plymouth-theme-target-2-git
+
+pkgname = plymouth-theme-tech-a-git
+
+pkgname = plymouth-theme-tech-b-git
+
+pkgname = plymouth-theme-unrap-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e4f9ba3007cf
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.SRCINFO
+!PKGBUILD
+!.gitignore
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8c140b7a3658
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,52 @@
+#Maintainer: Adrian Freund <adrian@freund.io>
+
+pkgbase=plymouth-themes-adi1090x-pack4-git
+_themenames=('red_loader'
+'rings'
+'rings_2'
+'rog'
+'rog_2'
+'seal'
+'seal_2'
+'seal_3'
+'sliced'
+'sphere'
+'spin'
+'spinner_alt'
+'splash'
+'square'
+'square_hud'
+'target'
+'target_2'
+'tech_a'
+'tech_b'
+'unrap')
+
+pkgname=() #initialized by loop at the bottom
+pkgver=r28.32a0d92
+pkgrel=1
+pkgdesc="The plymouth theme collection by adi1090x"
+arch=('any')
+url="https://github.com/adi1090x/plymouth-themes"
+license=('GPL')
+depends=('plymouth')
+
+source=("git+https://github.com/adi1090x/plymouth-themes.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "plymouth-themes"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+for themename in ${_themenames[*]}
+do
+ pkgname+=("plymouth-theme-${themename//_/-}-git")
+ eval "
+package_plymouth-theme-${themename//_/-}-git() {
+ cd \$srcdir/plymouth-themes/pack_4/$themename
+ mkdir -p \$pkgdir/usr/share/plymouth/themes/$themename
+ find . -type f -exec install -Dm644 \"{}\" \"\${pkgdir}\"/usr/share/plymouth/themes/$themename/\"{}\" \\;
+}
+"
+done