summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAanok2018-08-07 13:19:00 +0200
committerAanok2018-08-07 13:19:00 +0200
commit71d8c517e5255c5da37b30250e88d6b6a6832bc9 (patch)
tree17e1f30ba71494cc4eca411a168c04cebd4c084c
downloadaur-71d8c517e5255c5da37b30250e88d6b6a6832bc9.tar.gz
Initial commit.
-rwxr-xr-x.SRCINFO19
-rwxr-xr-xPKGBUILD29
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100755
index 000000000000..f3a5533e004a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = pmcli-git
+ pkgdesc = Command line client for Plex Media Server
+ pkgver = r50.b3a038f
+ pkgrel = 1
+ url = https://github.com/Aanok/pmcli
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ depends = lua
+ depends = lua-http
+ depends = lua-dkjson
+ depends = lua-html-entities
+ depends = mpv
+ provides = pmcli
+ source = git+https://github.com/Aanok/pmcli.git
+ md5sums = SKIP
+
+pkgname = pmcli-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..82e95d694f9b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Aanok <aanok.aur@gmail.com>
+pkgname=pmcli-git
+pkgver=r50.b3a038f
+pkgrel=1
+pkgdesc="Command line client for Plex Media Server"
+arch=('x86_64')
+url="https://github.com/Aanok/pmcli"
+license=('MIT')
+depends=('lua' 'lua-http' 'lua-dkjson' 'lua-html-entities' 'mpv')
+makedepends=('git')
+provides=("${pkgname%-git}")
+source=('git+https://github.com/Aanok/pmcli.git')
+md5sums=('SKIP')
+pkgver() {
+ cd "${pkgname%-git}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+package() {
+ cd "$srcdir/${pkgname%-git}"
+ install -D -m644 LICENSE.md "${pkgdir}/usr/share/licenses/${pkgname%-git}/LICENSE.md"
+
+ cd "src"
+ for file in *.lua; do
+ install -D -m644 "$file" "${pkgdir}/usr/share/lua/5.3/pmcli/$file"
+ done
+
+ sed -i 's/^/#!\/bin\/env lua\n/' pmcli.sh
+ install -D -m655 pmcli.sh "${pkgdir}/usr/local/bin/pmcli"
+} \ No newline at end of file