summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJames An2018-03-17 15:42:56 -0400
committerJames An2018-03-17 15:42:56 -0400
commitbeef22d1b933396237f8b00b21aef6bae8a97ebd (patch)
treeea39b313cd8d7f161bb1509d8bad4b4da60efb7b
parent591e5679fc2460acb698dd17fe47f8eca44c80af (diff)
downloadaur-beef22d1b933396237f8b00b21aef6bae8a97ebd.tar.gz
Removed unnecessary makedepends and obsolete patch.
-rw-r--r--PKGBUILD1
-rw-r--r--run.patch99
2 files changed, 0 insertions, 100 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e46d5781f8ed..70945cea1099 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,7 +10,6 @@ arch=('any')
url="http://pmd.github.io"
license=('BSD' 'Apache')
depends=('java-environment')
-makedepends=('unzip')
provides=("$_pkgname=$pkgver")
conflicts=("$_pkgname")
source=("https://github.com/$_pkgname/$_pkgname/releases/download/${_pkgname}_releases/$pkgver/$pkgname-$pkgver.zip"
diff --git a/run.patch b/run.patch
deleted file mode 100644
index fa7e07862065..000000000000
--- a/run.patch
+++ /dev/null
@@ -1,99 +0,0 @@
---- bin/run.sh 2015-01-07 06:40:19.614130823 -0500
-+++ bin/run.sh 2015-01-07 06:42:04.648794800 -0500
-@@ -5,7 +5,7 @@
- echo " $(basename $0) <application-name> [-h|-v] ..."
- echo ""
- echo "application-name: valid options are: $(valid_app_options)"
-- echo "-h print this help"
-+ echo "-h print this help"
- echo "-v display PMD's version"
- }
-
-@@ -13,37 +13,6 @@
- echo "pmd, cpd, cpdgui, designer, bgastviewer"
- }
-
--is_cygwin() {
-- case "$(uname)" in
-- CYGWIN*)
-- readonly cygwin=true
-- ;;
-- esac
-- # OS specific support. $var _must_ be set to either true or false.
-- if [ -z ${cygwin} ] ; then
-- readonly cygwin=false
-- fi
--}
--
--cygwin_paths() {
-- # For Cygwin, switch paths to Windows format before running java
-- if ${cygwin} ; then
-- JAVA_HOME=$(cygpath --windows "${JAVA_HOME}")
-- classpath=$(cygpath --path --windows "${classpath}")
-- DIRECTORY=$(cygpath --windows "${DIRECTORY}")
-- fi
--}
--
--convert_cygwin_vars() {
-- # If cygwin, convert to Unix form before manipulating
-- if ${cygwin} ; then
-- [ -n "${JAVA_HOME}" ] &&
-- JAVA_HOME=$(cygpath --unix "${JAVA_HOME}")
-- [ -n "${CLASSPATH}" ] &&
-- CLASSPATH=$(cygpath --path --unix "${CLASSPATH}")
-- fi
--}
--
- java_heapsize_settings() {
- local heapsize=${HEAPSIZE}
- case "${heapsize}" in
-@@ -58,24 +27,6 @@
- esac
- }
-
--
--set_lib_dir() {
-- if [ -z ${LIB_DIR} ]; then
-- local script_dir=$(dirname ${0})
-- local cwd="${PWD}"
--
-- cd "${script_dir}/../lib"
-- readonly LIB_DIR=$(pwd -P)
-- cd "${cwd}"
-- fi
--}
--
--check_lib_dir() {
-- if [ ! -e "${LIB_DIR}" ]; then
-- echo "The jar directory [${LIB_DIR}] does not exist"
-- fi
--}
--
- readonly APPNAME="${1}"
- if [ -z "${APPNAME}" ]; then
- usage
-@@ -104,23 +55,6 @@
- ;;
- esac
-
--is_cygwin
--
--set_lib_dir
--check_lib_dir
--
--convert_cygwin_vars
--
--classpath=$CLASSPATH
--
--cd "${CWD}"
--
--for jarfile in ${LIB_DIR}/*.jar; do
-- classpath=$classpath:$jarfile
--done
--
--cygwin_paths
--
- java_heapsize_settings
-
--java ${HEAPSIZE} -cp "${classpath}" "${CLASSNAME}" ${@}
-+java ${HEAPSIZE} -Djava.ext.dirs=/usr/share/java/pmd "${CLASSNAME}" ${@}