summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Yan2015-07-23 20:17:29 +0800
committerFelix Yan2015-07-23 20:17:29 +0800
commitb4e55a2687e3f121f3cae9ad9fab98ab0d6df163 (patch)
treed85ac181893ef93616faf9dffe798b17e365f76d
downloadaur-pmgmusic.tar.gz
Initial import
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD32
-rw-r--r--fix_glade_path.patch11
3 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9fcffbe18a83
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = pmgmusic
+ pkgdesc = PMG - a VOS clone for linux
+ pkgver = 1.0
+ pkgrel = 2
+ url = https://github.com/felixonmars/pmgmusic
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = popt
+ depends = alsa-lib
+ depends = gtk2
+ depends = glib2
+ depends = libglade
+ optdepends = fluidsynth
+ optdepends = timidity++
+ source = fix_glade_path.patch
+ source = https://github.com/felixonmars/pmgmusic/archive/v1.0.tar.gz
+ md5sums = 68f454557d83a0c1e9d9d0083011bbfb
+ md5sums = 4661f5d0ed0715587efd3c92993499f7
+
+pkgname = pmgmusic
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..637f275f2962
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Felix Yan <felixonmars@gmail.com>
+
+pkgname=pmgmusic
+pkgver=1.0
+pkgrel=2
+pkgdesc="PMG - a VOS clone for linux"
+arch=('i686' 'x86_64')
+url="https://github.com/felixonmars/pmgmusic"
+license=('GPL')
+depends=("popt" "alsa-lib" "gtk2" "glib2" "libglade")
+optdepends=('fluidsynth' 'timidity++')
+source=(
+ 'fix_glade_path.patch'
+ "https://github.com/felixonmars/pmgmusic/archive/v${pkgver}.tar.gz"
+)
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ patch -Np1 -i ../fix_glade_path.patch
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ install -Dm755 pmg "$pkgdir/usr/bin/pmg"
+ install -Dm755 dump_vos "$pkgdir/usr/bin/dump_vos"
+ install -Dm644 pmg.glade "$pkgdir/usr/share/pmgmusic/pmg.glade"
+}
+md5sums=('68f454557d83a0c1e9d9d0083011bbfb'
+ '4661f5d0ed0715587efd3c92993499f7')
diff --git a/fix_glade_path.patch b/fix_glade_path.patch
new file mode 100644
index 000000000000..49fdefde44dc
--- /dev/null
+++ b/fix_glade_path.patch
@@ -0,0 +1,11 @@
+--- A/pmg.c 2012-04-05 16:04:17.362043894 +0800
++++ B/pmg.c 2012-04-05 16:05:32.915373721 +0800
+@@ -302,7 +302,7 @@
+
+ #define NCOLOR 107
+
+-static const char *glade_fname = "pmg.glade";
++static const char *glade_fname = "/usr/share/pmgmusic/pmg.glade";
+ static const double vx_min = -0.1, vx_max = 7.1, vx_mid = 3.5, vy_min = -1.0, vy_max = 0.2;
+ static const double note_vw = 0.1; /* width of long note borders */
+ static const double note_vt = 0.01;