summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Yan2015-07-23 20:18:11 +0800
committerFelix Yan2015-07-23 20:18:11 +0800
commit5523fc9ac287f616eba3c877caf4f7d0a28b58df (patch)
tree1ac4261624bd9cd5f00cc5eb7a885b684c73ff9a
downloadaur-pmgmusic-git.tar.gz
Initial import
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD35
-rw-r--r--fix_glade_path.patch11
3 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..79a25c47cc93
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = pmgmusic-git
+ pkgdesc = PMG - a VOS clone for linux - Git version
+ pkgver = v1.0
+ pkgrel = 1
+ url = https://github.com/felixonmars/pmgmusic
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = timidity++
+ depends = alsa-lib
+ depends = gtk2
+ depends = glib2
+ depends = libglade
+ provides = pmgmusic
+ source = git://github.com/felixonmars/pmgmusic.git
+ source = fix_glade_path.patch
+ md5sums = SKIP
+ md5sums = 68f454557d83a0c1e9d9d0083011bbfb
+
+pkgname = pmgmusic-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ffafbc195eed
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Felix Yan <felixonmars@gmail.com>
+
+pkgname=pmgmusic-git
+_gitname=pmgmusic
+pkgver=v1.0
+pkgrel=1
+pkgdesc="PMG - a VOS clone for linux - Git version"
+arch=('i686' 'x86_64')
+url="https://github.com/felixonmars/pmgmusic"
+license=('GPL')
+depends=("timidity++" "alsa-lib" "gtk2" "glib2" "libglade")
+provides=("pmgmusic")
+source=("git://github.com/felixonmars/pmgmusic.git"
+ fix_glade_path.patch)
+md5sums=('SKIP'
+ '68f454557d83a0c1e9d9d0083011bbfb')
+
+pkgver() {
+ cd "$srcdir/$_gitname"
+ git describe --always | sed 's|-|.|g'
+}
+
+build() {
+ cd "$srcdir/$_gitname"
+ patch -Np1 -i ../fix_glade_path.patch
+ make
+}
+
+package() {
+ cd "$srcdir/$_gitname"
+
+ install -Dm755 pmg $pkgdir/usr/bin/pmg
+ install -Dm755 dump_vos $pkgdir/usr/bin/dump_vos
+ install -Dm644 pmg.glade $pkgdir/usr/share/pmgmusic/pmg.glade
+}
diff --git a/fix_glade_path.patch b/fix_glade_path.patch
new file mode 100644
index 000000000000..49fdefde44dc
--- /dev/null
+++ b/fix_glade_path.patch
@@ -0,0 +1,11 @@
+--- A/pmg.c 2012-04-05 16:04:17.362043894 +0800
++++ B/pmg.c 2012-04-05 16:05:32.915373721 +0800
+@@ -302,7 +302,7 @@
+
+ #define NCOLOR 107
+
+-static const char *glade_fname = "pmg.glade";
++static const char *glade_fname = "/usr/share/pmgmusic/pmg.glade";
+ static const double vx_min = -0.1, vx_max = 7.1, vx_mid = 3.5, vy_min = -1.0, vy_max = 0.2;
+ static const double note_vw = 0.1; /* width of long note borders */
+ static const double note_vt = 0.01;