summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwillemw122017-04-23 11:40:29 +0200
committerwillemw122017-04-23 11:40:29 +0200
commit3ad1c40cba993566b0fa7f7839fe28d7d3605fa5 (patch)
treef91debe7ddd3ad538f90a0906d4c94057077296d
parent39c1db502e1d66d6547dcdcc43b12901bc9ea3e3 (diff)
downloadaur-3ad1c40cba993566b0fa7f7839fe28d7d3605fa5.tar.gz
Update build and install. Remove patches...
Add cmake. Remove intltool. Fix install prefix (call build commands directly instead of rebuild.sh) Remove patches (boost_regex, rebuild.sh configure, "undefined reference" errors).
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD30
2 files changed, 9 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7fb55bc62add..7c05aa16209d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,16 @@
# Generated by mksrcinfo v8
-# Mon Jan 4 11:54:13 UTC 2016
+# Sun Apr 23 09:25:35 UTC 2017
pkgbase = pmus-git
pkgdesc = Practical Music Search is a highly configurable, ncurses-based client for MPD
- pkgver = 0.42.r351.g786cbfd
+ pkgver = 0.42.r392.gb3d3ed3
pkgrel = 1
url = https://ambientsound.github.io/pms/
arch = i686
arch = x86_64
license = GPL
+ makedepends = cmake
makedepends = git
makedepends = pandoc
- depends = intltool
depends = libmpdclient
depends = ncurses
provides = pmus
diff --git a/PKGBUILD b/PKGBUILD
index 47be0ed6e04e..55a6940d4b1a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,19 +3,14 @@
_pkgname=pmus
pkgname=$_pkgname-git
-pkgver=0.42.r351.g786cbfd
+pkgver=0.42.r392.gb3d3ed3
pkgrel=1
pkgdesc="Practical Music Search is a highly configurable, ncurses-based client for MPD"
arch=('i686' 'x86_64')
url="https://ambientsound.github.io/pms/"
license=('GPL')
-
-# Enable boost_regex
-#makedepends=('boost')
-#depends=('boost-libs' 'intltool' 'libmpdclient' 'ncurses')
-
-makedepends=('git' 'pandoc')
-depends=('intltool' 'libmpdclient' 'ncurses')
+makedepends=('cmake' 'git' 'pandoc')
+depends=('libmpdclient' 'ncurses')
provides=($_pkgname)
conflicts=($_pkgname)
source=($pkgname::git://github.com/ambientsound/pms.git)
@@ -26,29 +21,16 @@ pkgver() {
git describe --long --tags --match "[0-9]*" | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
-prepare() {
- cd $pkgname
-
- # Enable boost_regex
- #sed -i 's|^./configure[ ]*$|./configure --enable-regex --prefix=/usr|' rebuild.sh
-
- sed -i 's|^./configure[ ]*$|./configure --prefix=/usr|' rebuild.sh
-}
-
build() {
cd $pkgname
-
- # A fix for "undefined reference" errors: remove -D_FORTIFY_SOURCE=2 and -O2 from build flags
- CPPFLAGS="$(echo $CPPFLAGS | sed "s|-D_FORTIFY_SOURCE=\w||g")"
- CFLAGS="$(echo $CFLAGS | sed "s|-O\w||g")"
- CXXFLAGS="$(echo $CXXFLAGS | sed "s|-O\w||g")"
-
- ./rebuild.sh
+ cmake -DCMAKE_INSTALL_PREFIX=/usr .
+ make
}
package() {
cd $pkgname
make DESTDIR="$pkgdir/" install
+
install -dm755 "$pkgdir/usr/share/pms/examples"
install -m644 examples/* "$pkgdir/usr/share/pms/examples"
}