summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwillemw122015-09-13 10:53:04 +0200
committerwillemw122015-09-13 10:53:04 +0200
commit64b1c7eb0ab503fe725ab22c4631187aeb68866f (patch)
treef9f23f0c7321cc44c5dd6b4482af2fe86a47840b
downloadaur-64b1c7eb0ab503fe725ab22c4631187aeb68866f.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD48
2 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e3bda1d63904
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = pmus-git
+ pkgdesc = Practical Music Search is a highly configurable, ncurses-based client for MPD
+ pkgver = 0.42.r297.g3e476e9
+ pkgrel = 1
+ url = https://ambientsound.github.io/pms/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = intltool
+ depends = libmpdclient
+ depends = ncurses
+ provides = pmus
+ conflicts = pmus
+ source = pmus-git::git://github.com/ambientsound/pms.git
+ md5sums = SKIP
+
+pkgname = pmus-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f3ebfbbe7974
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Maintainer: willemw <willemw12@gmail.com>
+# Contributor: totoloco <totoloco at gmail dot com>
+
+_pkgname=pmus
+pkgname=$_pkgname-git
+pkgver=0.42.r297.g3e476e9
+pkgrel=1
+pkgdesc="Practical Music Search is a highly configurable, ncurses-based client for MPD"
+arch=('i686' 'x86_64')
+url="https://ambientsound.github.io/pms/"
+license=('GPL')
+
+# boost_regex
+#makedepends=('boost')
+#depends=('boost-libs' 'intltool' 'libmpdclient' 'ncurses')
+
+depends=('intltool' 'libmpdclient' 'ncurses')
+provides=($_pkgname)
+conflicts=($_pkgname)
+source=($pkgname::git://github.com/ambientsound/pms.git)
+md5sums=(SKIP)
+
+pkgver() {
+ cd $pkgname
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd $pkgname
+
+ # boost_regex
+ #sed -i 's|^./configure[ ]*$|./configure --enable-regex --prefix=/usr|' rebuild.sh
+
+ sed -i 's|^./configure[ ]*$|./configure --prefix=/usr|' rebuild.sh
+}
+
+build() {
+ cd $pkgname
+ ./rebuild.sh
+}
+
+package() {
+ cd $pkgname
+ make DESTDIR="$pkgdir/" install
+ install -dm755 "$pkgdir/usr/share/pms/examples"
+ install -m644 examples/* "$pkgdir/usr/share/pms/examples"
+}
+