summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwillemw122021-06-25 13:26:06 +0200
committerwillemw122021-06-25 13:26:06 +0200
commitbbd585cbc6185ba97af642f821d060f1bcc47031 (patch)
tree491982e3a20f38b94c5c40418083e8a32c5e909f
parent28a9bf6de8a32cbc43d98e13ac24acffa70d34c7 (diff)
downloadaur-bbd585cbc6185ba97af642f821d060f1bcc47031.tar.gz
Update cmake build
Update arch. Change source URL from git:// to git+https://. Change pkgver() and package().
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD31
2 files changed, 17 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e7d49072b8b9..a794ff316ce9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,8 @@
-# Generated by mksrcinfo v8
-# Mon May 22 16:22:43 UTC 2017
pkgbase = pmus-git
pkgdesc = Practical Music Search is a highly configurable, ncurses-based client for MPD
- pkgver = 0.42.r399.g8c89184
+ pkgver = 0.42.r401.g318d75a
pkgrel = 1
- url = https://ambientsound.github.io/pms/
- arch = i686
+ url = https://ambientsound.github.io/pms
arch = x86_64
license = GPL
makedepends = cmake
@@ -15,8 +12,7 @@ pkgbase = pmus-git
depends = ncurses
provides = pmus
conflicts = pmus
- source = pmus-git::git://github.com/ambientsound/pms.git#branch=0.42.x
- md5sums = SKIP
+ source = pmus-git::git+https://github.com/ambientsound/pms.git#branch=0.42.x
+ sha256sums = SKIP
pkgname = pmus-git
-
diff --git a/PKGBUILD b/PKGBUILD
index c8170a45ed1f..ea2f3c788e16 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,37 +1,32 @@
# Maintainer: willemw <willemw12@gmail.com>
# Contributor: totoloco <totoloco at gmail dot com>
-_pkgname=pmus
-pkgname=$_pkgname-git
-pkgver=0.42.r399.g8c89184
+pkgname=pmus-git
+pkgver=0.42.r401.g318d75a
pkgrel=1
pkgdesc="Practical Music Search is a highly configurable, ncurses-based client for MPD"
-arch=('i686' 'x86_64')
-url="https://ambientsound.github.io/pms/"
+arch=('x86_64')
+url="https://ambientsound.github.io/pms"
license=('GPL')
makedepends=('cmake' 'git' 'pandoc')
depends=('libmpdclient' 'ncurses')
-provides=($_pkgname)
-conflicts=($_pkgname)
-source=($pkgname::git://github.com/ambientsound/pms.git#branch=0.42.x)
-md5sums=(SKIP)
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=($pkgname::git+https://github.com/ambientsound/pms.git#branch=0.42.x)
+sha256sums=('SKIP')
pkgver() {
- cd $pkgname
- git describe --long --tags --match "[0-9]*" | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ git -C $pkgname describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- cd $pkgname
- cmake -DCMAKE_INSTALL_PREFIX=/usr .
- make
+ cmake -B build -S $pkgname -DCMAKE_BUILD_TYPE=None -DCMAKE_INSTALL_PREFIX=/usr -Wno-dev
+ make -C build
}
package() {
- cd $pkgname
- make DESTDIR="$pkgdir/" install
-
install -dm755 "$pkgdir/usr/share/pms/examples"
- install -m644 examples/* "$pkgdir/usr/share/pms/examples"
+ install -m644 $pkgname/examples/* "$pkgdir/usr/share/pms/examples"
+ make -C build DESTDIR="$pkgdir/" install
}