summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAloxaf2019-12-21 17:28:04 +0800
committerAloxaf2019-12-21 17:28:04 +0800
commit01f52987d8796c35c92a3fd18b65999ab6931369 (patch)
tree953c10b36427f182c85dc5550b4e48a92c6bdc7a
downloadaur-01f52987d8796c35c92a3fd18b65999ab6931369.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD21
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1b3d2b63fa90
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = pmy-bin
+ pkgdesc = General purpose context-aware zsh completion engine powered by fuzzy finder.
+ pkgver = 0.5.2
+ pkgrel = 1
+ url = https://github.com/relastle/pmy
+ arch = i386
+ arch = x86_64
+ license = MIT
+ depends = fzf
+ depends = zsh
+ provides = pmy
+ source_x86_64 = pmy-bin-0.5.2.tar.gz::https://github.com/relastle/pmy/releases/download/v0.5.2/pmy_0.5.2_Linux_x86_64.tar.gz
+ sha256sums_x86_64 = 9c5e44f6a1f3ba53df5f439351a12eacc52ee0dc480459e43cb242a246d43fbe
+
+pkgname = pmy-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7e76cda0773a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Aloxaf <aloxafx@gmail.com>
+
+pkgname=pmy-bin
+pkgver=0.5.2
+pkgrel=1
+pkgdesc="General purpose context-aware zsh completion engine powered by fuzzy finder."
+arch=('i386' 'x86_64')
+depends=('fzf' 'zsh')
+provides=('pmy')
+url="https://github.com/relastle/pmy"
+license=('MIT')
+source_i686=("$pkgname-$pkgver.tar.gz::https://github.com/relastle/pmy/releases/download/v$pkgver/pmy_${pkgver}_Linux_i386.tar.gz")
+source_x86_64=("$pkgname-$pkgver.tar.gz::https://github.com/relastle/pmy/releases/download/v$pkgver/pmy_${pkgver}_Linux_x86_64.tar.gz")
+sha256sums_i686=('03e0d50014695e4cd3c22c139f80e0b7de6f4afdd9bd3a3ffe94d8b95656d44f')
+sha256sums_x86_64=('9c5e44f6a1f3ba53df5f439351a12eacc52ee0dc480459e43cb242a246d43fbe')
+
+package() {
+ install -Dm755 "pmy" "$pkgdir/usr/bin/pmy"
+ install -Dm644 "LICENSE" "$pkgdir/usr/share/licenses/pmy/LICENSE"
+ install -Dm644 "README.md" "$pkgdir/usr/share/docs/pmy/READNE.md"
+}