summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRudy Matela2015-06-13 19:27:48 +0200
committerRudy Matela2015-06-13 19:27:48 +0200
commitb7701560d41b04f66569d86e282a3c23ef001d40 (patch)
tree175bb579a6b8751ec63b1ff158bd53306adce5c8
downloadaur-b7701560d41b04f66569d86e282a3c23ef001d40.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD30
-rw-r--r--makefile.patch13
3 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8dcb94f77151
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = pngcheck
+ pkgdesc = Verifies the integrity of PNG, JNG and MNG files by checking the CRCs and decompressing the image data
+ pkgver = 2.3.0
+ pkgrel = 1
+ url = http://www.libpng.org/pub/png/apps/pngcheck.html
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = libpng
+ depends = libpng
+ source = http://sourceforge.net/projects/png-mng/files/pngcheck/2.3.0/pngcheck-2.3.0.tar.gz
+ source = makefile.patch
+ md5sums = 980bd6d9a3830fdce746d7fe3c9166ee
+ md5sums = bd6f2e05f4914e9e271e3b844b489c40
+
+pkgname = pngcheck
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b27d70ebb125
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Contributor: Rudy Matela <rudy@matela.com.br>
+# Maintainer: Rudy Matela <rudy@matela.com.br>
+pkgname=pngcheck
+pkgver=2.3.0
+pkgrel=1
+pkgdesc="Verifies the integrity of PNG, JNG and MNG files by checking the CRCs and decompressing the image data"
+arch=('i686' 'x86_64')
+url="http://www.libpng.org/pub/png/apps/pngcheck.html"
+license=('GPL')
+depends=('libpng')
+makedepends=('libpng')
+source=("http://sourceforge.net/projects/png-mng/files/$pkgname/$pkgver/$pkgname-${pkgver}.tar.gz"
+ 'makefile.patch')
+md5sums=('980bd6d9a3830fdce746d7fe3c9166ee' 'bd6f2e05f4914e9e271e3b844b489c40')
+
+build() {
+ cd $srcdir/$pkgname-$pkgver
+ cp Makefile.unx Makefile || return 1
+ patch -p0 < $srcdir/makefile.patch || return 1
+ make || return 1
+ return 0
+}
+
+package() {
+ cd $srcdir/$pkgname-$pkgver
+ install -Dm755 pngcheck $pkgdir/usr/bin/pngcheck || return 1
+ install -Dm755 pngsplit $pkgdir/usr/bin/pngsplit || return 1
+ install -Dm755 png-fix-IDAT-windowsize $pkgdir/usr/bin/png-fix-IDAT-windowsize || return 1
+ return 0
+}
diff --git a/makefile.patch b/makefile.patch
new file mode 100644
index 000000000000..7ccf20e782c5
--- /dev/null
+++ b/makefile.patch
@@ -0,0 +1,13 @@
+--- Makefile 2006-06-17 19:47:35.000000000 -0300
++++ Makefile 2013-02-14 10:33:52.762905241 -0300
+@@ -23,8 +23,8 @@
+ #ZLIB = -L$(ZPATH) -lz
+ ZLIB = $(ZPATH)/libz.a
+
+-INCS = $(ZINC)
+-LIBS = $(ZLIB)
++INCS =
++LIBS = -lz
+
+ CC = gcc
+ LD = gcc