summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBermond2016-02-13 14:45:27 -0200
committerBermond2016-02-13 14:45:27 -0200
commitfcbec8263b05afad4b539c9028c20d1ecd88472c (patch)
treea5128a48141a5ea842153263c5ba5d2993047fbe
parent3a4e6e268c7a983edadac42869ac1abbdb558aa5 (diff)
downloadaur-fcbec8263b05afad4b539c9028c20d1ecd88472c.tar.gz
Changed Makefile FLAGS assignment from = to +=
Changed CPPFLAGS, CFLAGS and LDFLAGS assignment from = to += in Makefile. In this way the compilation procedure will also use flags defined in /etc/makepkg.conf.
-rw-r--r--.SRCINFO4
-rwxr-xr-xPKGBUILD10
2 files changed, 11 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b4a9fba569d6..096b3265efd5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Sat Feb 13 16:04:15 UTC 2016
+# Sat Feb 13 16:43:12 UTC 2016
pkgbase = pngcrush-bundled
pkgdesc = A tool for optimizing the compression of PNG files (with bundled libpng and zlib)
pkgver = 1.8.0
- pkgrel = 1
+ pkgrel = 2
url = http://pmt.sourceforge.net/pngcrush/
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index aa38f99428c8..01fff90d7ef0 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -15,7 +15,7 @@
_srcname=pngcrush
pkgname=pngcrush-bundled
pkgver=1.8.0
-pkgrel=1
+pkgrel=2
pkgdesc="A tool for optimizing the compression of PNG files (with bundled libpng and zlib)"
arch=('i686' 'x86_64')
url="http://pmt.sourceforge.net/pngcrush/"
@@ -26,6 +26,14 @@ conflicts=('pngcrush')
source=("https://sourceforge.net/projects/pmt/files/pngcrush/${pkgver}/pngcrush-${pkgver}.tar.xz")
sha256sums=('94491583c625e284e580f102657f9c2b3036372ab486e08682112f6cbb66522c')
+prepare() {
+ cd "$_srcname"-"$pkgver"
+
+ sed -r 's|^(CPPFLAGS )=|\1+=|' -i Makefile
+ sed -r 's|^(CFLAGS )=|\1+=|' -i Makefile
+ sed -r 's|^(LDFLAGS )=|\1+=|' -i Makefile
+}
+
build() {
cd "$_srcname"-"$pkgver"