summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrien Smith2019-05-13 17:40:23 -0600
committerAdrien Smith2019-05-13 17:40:23 -0600
commit16c6294fcd385363c2b34f57abff5526f321efd1 (patch)
tree0ede6fcfa1a4a68edf29a724cc5a5084ee3c10da
parent824a92db99ebea4a7eca0981d4e8fd780b2e157f (diff)
downloadaur-16c6294fcd385363c2b34f57abff5526f321efd1.tar.gz
Improve PKGBUILD, bump pkgrel due to changed checksums
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD24
2 files changed, 15 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2c4b0f1e8880..1ba44785321e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = pngout
pkgdesc = Lossless PNG compressor
pkgver = 20150319
- pkgrel = 1
+ pkgrel = 2
url = http://www.jonof.id.au/kenutils
arch = i686
arch = x86_64
@@ -10,12 +10,9 @@ pkgbase = pngout
source = http://static.jonof.id.au/dl/kenutils/pngout-20150319-linux.tar.gz
source = pngout.completion
source = LICENSE
- md5sums = a48761bb753622c846b4846be60c7e4b
- md5sums = 99a75d19ff6278f04c66358ce67e8eed
- md5sums = 6aca04829b82718d2cb26c9b45f9a570
- sha256sums = 078a9ec068cc4d79ceca332b9e2117151c4584ee0e917e253d4fe80703499b47
- sha256sums = 8952df609f738751d5830f431d3da23f7551b8796d773665baa8d10b5ea11074
- sha256sums = eb52d51be70d26eb7dfca460fafe50f8e5e36937b9e9bce68a5a079d4951a592
+ sha512sums = 5700fd502c9c717ce8be37aedf0cbc512cc2a9e6197df9ac94bd38755f3c0b627b5acc5f5bf3da5ba8435698871334896876a44a716a0a1b08e685d95df60913
+ sha512sums = 0401518413a4f2dbfe648e5f5e5c14f472223f4612ce57bacaabfd8077f8bd08b5ebec25d59e5868807c5004829cd1cc7e782e5f945c8c4959ce13eafb44c8de
+ sha512sums = 0ca45cfd8c5963948cae63ab79339d7f33a1be4585fb8b94c8773771f4b33d6a6f3e854dd3abd68b0c13eec013d98d6406cd81af08a357265ee64c93dc203896
pkgname = pngout
diff --git a/PKGBUILD b/PKGBUILD
index 63c947a998d4..487010990d7b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,3 +1,4 @@
+#!/hint/bash -e
# Maintainer: Adrien Smith <adrien[at]bouldersmiths[dot]com>
# Contributor: Timothy Redaelli <timothy.redaelli@gmail.com>
# Contributor: DrZaius <lou[at]fakeoutdoorsman[dot]com>
@@ -5,25 +6,22 @@
pkgname=pngout
pkgver=20150319
-pkgrel=1
+pkgrel=2
pkgdesc="Lossless PNG compressor"
arch=('i686' 'x86_64')
url="http://www.jonof.id.au/kenutils"
license=('custom')
depends=('glibc')
-source=("http://static.jonof.id.au/dl/kenutils/${pkgname}-${pkgver}-linux.tar.gz"
- pngout.completion
- LICENSE)
-md5sums=('a48761bb753622c846b4846be60c7e4b'
- '99a75d19ff6278f04c66358ce67e8eed'
- '6aca04829b82718d2cb26c9b45f9a570')
-sha256sums=('078a9ec068cc4d79ceca332b9e2117151c4584ee0e917e253d4fe80703499b47'
- '8952df609f738751d5830f431d3da23f7551b8796d773665baa8d10b5ea11074'
- 'eb52d51be70d26eb7dfca460fafe50f8e5e36937b9e9bce68a5a079d4951a592')
+source=("http://static.jonof.id.au/dl/kenutils/$pkgname-$pkgver-linux.tar.gz"
+ 'pngout.completion'
+ 'LICENSE')
+sha512sums=('5700fd502c9c717ce8be37aedf0cbc512cc2a9e6197df9ac94bd38755f3c0b627b5acc5f5bf3da5ba8435698871334896876a44a716a0a1b08e685d95df60913'
+ '0401518413a4f2dbfe648e5f5e5c14f472223f4612ce57bacaabfd8077f8bd08b5ebec25d59e5868807c5004829cd1cc7e782e5f945c8c4959ce13eafb44c8de'
+ '0ca45cfd8c5963948cae63ab79339d7f33a1be4585fb8b94c8773771f4b33d6a6f3e854dd3abd68b0c13eec013d98d6406cd81af08a357265ee64c93dc203896')
package() {
- install -Dm755 "${srcdir}/${pkgname}-${pkgver}-linux/${CARCH}/pngout" \
+ install -Dm755 "$pkgname-$pkgver-linux/${CARCH}/pngout" \
"${pkgdir}/usr/bin/pngout"
- install -Dm644 "${srcdir}/pngout.completion" "${pkgdir}/etc/bash_completion.d/pngout"
- install -Dm644 "${srcdir}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm644 "pngout.completion" "${pkgdir}/etc/bash_completion.d/pngout"
+ install -Dm644 "LICENSE" "${pkgdir}/usr/share/licenses/$pkgname/LICENSE"
}