summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTimothy Redaelli2015-07-14 15:21:37 +0200
committerTimothy Redaelli2015-07-14 15:21:37 +0200
commitc7f739cb2bf0c732dcafbe499d7fa1d23e81fbee (patch)
tree4a77ef794a2ed79b661f74580d024a986e89d83d
downloadaur-c7f739cb2bf0c732dcafbe499d7fa1d23e81fbee.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--LICENSE6
-rw-r--r--PKGBUILD24
-rw-r--r--pngout.completion1
4 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0c2fce91ba45
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = pngout
+ pkgdesc = Lossless PNG compressor
+ pkgver = 20150319
+ pkgrel = 1
+ url = http://www.jonof.id.au/kenutils
+ arch = i686
+ arch = x86_64
+ license = custom
+ source = http://static.jonof.id.au/dl/kenutils/pngout-20150319-linux.tar.gz
+ source = pngout.completion
+ source = LICENSE
+ md5sums = a48761bb753622c846b4846be60c7e4b
+ md5sums = 99a75d19ff6278f04c66358ce67e8eed
+ md5sums = 6aca04829b82718d2cb26c9b45f9a570
+
+pkgname = pngout
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..3d893c565e61
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,6 @@
+PNGOUT / KZIP license
+http://www.advsys.net/ken/utils.htm#pngoutkziplicense
+
+The command line versions of PNGOUT.EXE and KZIP.EXE are free, as are the Mac and Linux ports. You may use PNGOUT- or KZIP-compressed content for non-commercial or commercial purposes.
+
+Redistributing, repackaging, or reusing the PNGOUT or KZIP executable is prohibited without the express consent of Ardfry Imaging, LLC, and a formal business agreement.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d8f9801f6c69
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Timothy Redaelli <timothy.redaelli@gmail.com>
+# Contributor: DrZaius <lou[at]fakeoutdoorsman[dot]com>
+# Contributor: gueek <cyttam[at]gmail[dot]com>
+
+pkgname=pngout
+pkgver=20150319
+pkgrel=1
+pkgdesc="Lossless PNG compressor"
+arch=('i686' 'x86_64')
+url="http://www.jonof.id.au/kenutils"
+license=('custom')
+source=(http://static.jonof.id.au/dl/kenutils/pngout-${pkgver}-linux.tar.gz
+ pngout.completion
+ LICENSE)
+md5sums=('a48761bb753622c846b4846be60c7e4b'
+ '99a75d19ff6278f04c66358ce67e8eed'
+ '6aca04829b82718d2cb26c9b45f9a570')
+
+package() {
+ install -Dm755 ${srcdir}/${pkgname}-${pkgver}-linux/${CARCH}/pngout \
+ ${pkgdir}/usr/bin/pngout
+ install -Dm644 ${srcdir}/pngout.completion ${pkgdir}/etc/bash_completion.d/pngout
+ install -Dm644 ${srcdir}/LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+}
diff --git a/pngout.completion b/pngout.completion
new file mode 100644
index 000000000000..92db6321c8b4
--- /dev/null
+++ b/pngout.completion
@@ -0,0 +1 @@
+complete -f -X '!*.png' pngout