summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorScore_Under2017-02-06 20:54:52 +0000
committerScore_Under2017-02-06 20:54:52 +0000
commitf65f59dc97d036fcb2cee24dc4e2d4188475d5b8 (patch)
tree2e60740c929b9515ff09ed858468042ed0174201
parent75785defb2587f8718ab61c3c2252458471f693a (diff)
downloadaur-f65f59dc97d036fcb2cee24dc4e2d4188475d5b8.tar.gz
Required changes to get the new version to build
- Update dependencies to include libdeflate - Also add libdeflate to the linker libs - Update CXXFLAGS to work around a mistake in the current source
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD15
2 files changed, 14 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f687da074c7c..1dfb01b13f00 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Sat Feb 6 10:34:51 UTC 2016
+# Mon Feb 6 20:54:13 UTC 2017
pkgbase = pngwolf-zopfli-git
pkgdesc = A PNG optimizer using a genetic algorithm to find effective compression parameters
- pkgver = 0.r51.a62b466
+ pkgver = 0.r76.952f812
pkgrel = 1
url = https://github.com/jibsen/pngwolf-zopfli
arch = i686
@@ -12,6 +12,7 @@ pkgbase = pngwolf-zopfli-git
makedepends = git
depends = libzopfli
depends = zlib
+ depends = libdeflate
provides = pngwolf
conflicts = pngwolf
source = git+https://github.com/jibsen/pngwolf-zopfli.git
diff --git a/PKGBUILD b/PKGBUILD
index 20380e241c7f..c191f9b7289a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,14 @@
# Maintainer: Score_Under <seejay.11@gmail.com>
pkgname=pngwolf-zopfli-git
-pkgver=0.r51.a62b466
+pkgver=0.r76.952f812
pkgrel=1
pkgdesc="A PNG optimizer using a genetic algorithm to find effective compression parameters"
arch=('i686' 'x86_64' 'armv7h')
url="https://github.com/jibsen/pngwolf-zopfli"
license=('GPL3')
-depends=(libzopfli zlib)
+# At the time of writing, you can get libdeflate as "libdeflate-git" from the
+# AUR.
+depends=(libzopfli zlib libdeflate)
makedepends=('git')
source=(git+https://github.com/jibsen/pngwolf-zopfli.git
http://lancet.mit.edu/ga/dist/galib247.tgz)
@@ -28,10 +30,15 @@ prepare() {
build() {
cd pngwolf-zopfli
- # Yes I know how morally wrong that awk is. What's worse is compiling it "by the book".
+ # Yes I know how morally wrong that awk is. What's worse is compiling it "by
+ # the book", because that requires checking out all the git submodules and
+ # prevents you from using dynamic libraries. Also, it's using Windows line
+ # endings -- for shame!
SOURCES="pngwolf.cxx $(awk '/^ *galib/{gsub("\r",""); print "../" $1}' CMakeLists.txt)"
CPPFLAGS="-I../galib $CPPFLAGS"
- LDLIBS="-lz -lzopfli $LDLIBS"
+ # -fpermissive required because the author tries to implicitly drop a const qualifier
+ CXXFLAGS="$CXXFLAGS -fpermissive"
+ LDLIBS="-lz -lzopfli -ldeflate $LDLIBS"
(
set -x
g++ -o pngwolf $SOURCES $CPPFLAGS $CXXFLAGS $LDFLAGS $LDLIBS