summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlchristian Eckert2015-08-31 20:23:32 +0200
committerCarlchristian Eckert2015-08-31 20:23:32 +0200
commite79872e5b1fd4d0c4706468df6af0c61e1a8ffb8 (patch)
tree4cb8a791f40e094c84a34c4ca2628c222a36240e
downloadaur-e79872e5b1fd4d0c4706468df6af0c61e1a8ffb8.tar.gz
initial upload
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD29
-rw-r--r--pngwriter-git.install3
4 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b1c831cab91c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = pngwriter-git
+ pkgdesc = A C++ library for creating PNG images
+ pkgver = 0.5.4.r111.g131d72f
+ pkgrel = 1
+ url = http://pngwriter.sourceforge.net/
+ install = pngwriter-git.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ source = pngwriter-git::git://github.com/pngwriter/pngwriter.git
+ sha256sums = SKIP
+
+pkgname = pngwriter-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..6c1df9ab31d8
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+pngwriter-git-*.pkg.tar.xz
+pngwriter-git/
+src/
+pkg/
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..31a12c395b1c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Carlchristian Eckert <carli-eckert at gmx dot de>
+
+pkgname=pngwriter-git
+pkgver=0.5.4.r111.g131d72f
+pkgrel=1
+pkgdesc="A C++ library for creating PNG images"
+url="http://pngwriter.sourceforge.net/"
+source=("${pkgname}::git://github.com/pngwriter/pngwriter.git")
+install=$pkgname.install
+license=('GPL')
+arch=('i686' 'x86_64')
+makedepends=('git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd $pkgname
+ git describe --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build(){
+ cd $pkgname
+ cmake -DCMAKE_INSTALL_PREFIX=/usr .
+ make
+}
+
+package() {
+ cd $pkgname
+ make DESTDIR="${pkgdir}" install
+}
diff --git a/pngwriter-git.install b/pngwriter-git.install
new file mode 100644
index 000000000000..8c58e7d01c17
--- /dev/null
+++ b/pngwriter-git.install
@@ -0,0 +1,3 @@
+post_install() {
+ echo 'If you want to use PNGwriter with CMake, you can find the appropriate CMake module at https://raw.githubusercontent.com/ComputationalRadiationPhysics/cmake-modules/dev/FindPNGwriter.cmake'
+}