summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrian Bidulock2016-09-18 18:45:09 -0600
committerBrian Bidulock2016-09-18 18:45:09 -0600
commit9a66d6da271109706de7a043458d0338f1a85da8 (patch)
treedb0d28b8a518183a016f0c04cc1d4619c1d33056
parent918c058e80d0ded76c88c48c47056269ad3d0e50 (diff)
downloadaur-9a66d6da271109706de7a043458d0338f1a85da8.tar.gz
version 0.7.r0.ge4dc99c-1
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD27
2 files changed, 16 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 380fe9e8649e..6c5ba94b36b7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,18 @@
pkgbase = pnmixer-git
- pkgdesc = Lightweight GTK3 volume control program that runs in the system tray
- pkgver = 0.5.r116.gd7c3ea0
+ pkgdesc = GTK volume mixer applet that runs in the system tray.
+ pkgver = 0.7.r0.ge4dc99c
pkgrel = 1
- epoch = 1
url = https://github.com/nicklan/pnmixer
arch = i686
arch = x86_64
license = GPL
makedepends = intltool
- depends = gtk3
+ depends = gtk2
depends = alsa-lib
- depends = libx11
depends = libnotify
provides = pnmixer
conflicts = pnmixer
- source = git://github.com/nicklan/pnmixer.git
+ source = pnmixer-git::git+https://github.com/nicklan/pnmixer.git
md5sums = SKIP
pkgname = pnmixer-git
diff --git a/PKGBUILD b/PKGBUILD
index 575da53a58be..4d9bbc6ddd59 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,30 @@
-# Maintainer: aminb <me@aminb.org>
-# Contributor: Steven Honeyman <stevenhoneyman at gmail com>
-
+# Maintainer: Brian Bidulock <bidulock@openss7.org>
pkgname=pnmixer-git
-pkgver=0.5.r116.gd7c3ea0
+pkgver=0.7.r0.ge4dc99c
pkgrel=1
-epoch=1
-pkgdesc="Lightweight GTK3 volume control program that runs in the system tray"
-url="https://github.com/nicklan/pnmixer"
-license=('GPL')
+pkgdesc="GTK volume mixer applet that runs in the system tray."
arch=('i686' 'x86_64')
-depends=('gtk3' 'alsa-lib' 'libx11' 'libnotify')
+license=('GPL')
+url="https://github.com/nicklan/pnmixer"
provides=('pnmixer')
conflicts=('pnmixer')
makedepends=('intltool')
-source=("git://github.com/nicklan/pnmixer.git")
+depends=('gtk2' 'alsa-lib' 'libnotify')
+source=("$pkgname::git+https://github.com/nicklan/pnmixer.git")
md5sums=('SKIP')
pkgver() {
- cd "$srcdir/pnmixer"
+ cd $pkgname
git describe --tags --long|sed -r 's,^[^0-9]*,,;s,([^-]*-g),r\1,;s,[-_],.,g'
}
build() {
- cd "$srcdir/pnmixer"
- ./autogen.sh --prefix=/usr --sysconfdir=/etc
- make
+ cd $pkgname
+ ./autogen.sh --without-gtk3 --prefix=/usr
+ make V=0
}
package() {
- cd "$srcdir/pnmixer"
+ cd $pkgname
make DESTDIR="$pkgdir" install
}