summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlastavengers2015-10-29 23:40:48 +0800
committerlastavengers2015-10-29 23:40:48 +0800
commit4eeb4fb8832b5df50467ab593faa0a55f1e1a6ca (patch)
tree316d918c14237374e568d6811cb034d740daf93b
downloadaur-4eeb4fb8832b5df50467ab593faa0a55f1e1a6ca.tar.gz
Initial import
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD28
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..909808ff00b2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = pnmixer-gtk3
+ pkgdesc = GTK volume mixer applet that runs in the system tray.
+ pkgver = 0.6.1
+ pkgrel = 1
+ url = https://github.com/nicklan/pnmixer
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = intltool
+ depends = gtk3
+ depends = alsa-lib
+ depends = libx11
+ depends = libnotify
+ conflicts = pnmixer-git
+ conflicts = pnmixer-gtk2
+ source = https://github.com/nicklan/pnmixer/archive/v0.6.1.tar.gz
+ sha512sums = 6980e54e1894e7ba9a54b3a7b794cebd065093682b0cd6b50f99b4fd2059ef966fd755a034e0055eec9c4ff9fec8215dd1f8c7e7cc2364c5e20f90f0c174f6a7
+
+pkgname = pnmixer-gtk3
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b78b4b9219d3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Yuexuan Gu <lastavengers@outlook.com>
+pkgname=pnmixer-gtk3
+pkgver=0.6.1
+pkgrel=1
+pkgdesc="GTK volume mixer applet that runs in the system tray."
+arch=('i686' 'x86_64')
+license=('GPL')
+url="https://github.com/nicklan/pnmixer"
+depends=('gtk3' 'alsa-lib' 'libx11' 'libnotify')
+makedepends=('intltool')
+conflicts=('pnmixer-git' 'pnmixer-gtk2')
+
+source=(https://github.com/nicklan/pnmixer/archive/v${pkgver}.tar.gz)
+sha512sums=('6980e54e1894e7ba9a54b3a7b794cebd065093682b0cd6b50f99b4fd2059ef966fd755a034e0055eec9c4ff9fec8215dd1f8c7e7cc2364c5e20f90f0c174f6a7')
+
+build() {
+ cd ${pkgname%-gtk3}-$pkgver
+
+ ./autogen.sh
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd ${pkgname%-gtk3}-$pkgver
+
+ make DESTDIR="$pkgdir" install
+}