summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPig Fang2023-02-12 17:13:15 +0800
committerPig Fang2023-02-12 17:13:15 +0800
commit65cb94ff41b31e6cead2d7634d9382665b108618 (patch)
treeed58b4192184ccd52bee66781f5f930a9e92215a
downloadaur-65cb94ff41b31e6cead2d7634d9382665b108618.tar.gz
0.2.0-1
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD17
-rw-r--r--pnpm-shell-completion.install6
3 files changed, 34 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..077f2976adae
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,11 @@
+pkgbase = pnpm-shell-completion
+ pkgdesc = Complete your pnpm command fastly.
+ pkgver = 0.1.3
+ pkgrel = 1
+ url = https://github.com/g-plane/pnpm-shell-completion
+ arch = x86_64
+ license = MIT
+ source = https://github.com/g-plane/pnpm-shell-completion/releases/download/v0.1.3/pnpm-shell-completion_x86_64-unknown-linux-gnu.tar.gz
+ sha256sums = 3976a533cc14aeaaec6d105799330fb9e9d2d8f998c8cc3598063c1ce284d8b1
+
+pkgname = pnpm-shell-completion
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..484d2fd1ab95
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,17 @@
+# Maintainer: Pig Fang <g-plane@hotmail.com>
+
+pkgname=pnpm-shell-completion
+pkgver=0.2.0
+pkgrel=1
+pkgdesc='Complete your pnpm command fastly.'
+arch=('x86_64')
+url='https://github.com/g-plane/pnpm-shell-completion'
+license=('MIT')
+source=("https://github.com/g-plane/pnpm-shell-completion/releases/download/v$pkgver/pnpm-shell-completion_$arch-unknown-linux-gnu.tar.gz")
+sha256sums=('3976a533cc14aeaaec6d105799330fb9e9d2d8f998c8cc3598063c1ce284d8b1')
+
+package() {
+ install -Dm755 pnpm-shell-completion $pkgdir/usr/bin/pnpm-shell-completion
+ install -Dm755 pnpm-shell-completion.plugin.zsh $pkgdir/usr/share/zsh/plugins/pnpm-shell-completion.zsh
+ install -Dm644 LICENSE $pkgdir/usr/share/licenses/$pkgname/LICENSE
+}
diff --git a/pnpm-shell-completion.install b/pnpm-shell-completion.install
new file mode 100644
index 000000000000..25849e3708ed
--- /dev/null
+++ b/pnpm-shell-completion.install
@@ -0,0 +1,6 @@
+post_install() {
+ cat << EOF
+To activate "pnpm-shell-completion", add the following line at the end of ~/.zshrc:
+ source /usr/share/zsh/plugins/pnpm-shell-completion/pnpm-shell-completion.zsh
+EOF
+}