summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorArtem Vorotnikov2015-07-04 22:37:43 +0300
committerArtem Vorotnikov2015-07-04 22:37:43 +0300
commitc52b61f9b780e500adfbaa86e0ea7860b67eb0e9 (patch)
treec2d2c5b1405d5dd402c838f3d0b71316405d85c1
downloadaur-c52b61f9b780e500adfbaa86e0ea7860b67eb0e9.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD30
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8d0f12b7f63f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = po4a-bulk-git
+ pkgdesc = Automation wrappers for po4a
+ pkgver = LATEST
+ pkgrel = 1
+ url = https://github.com/skybon/po4a-bulk
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = po4a
+ provides = po4a-bulk
+ source = git+https://github.com/skybon/po4a-bulk.git
+ sha512sums = SKIP
+
+pkgname = po4a-bulk-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8c758c2d5008
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Artem Vorotnikov <artem@vorotnikov.me>
+
+_pkgname=po4a-bulk
+_gitname=po4a-bulk
+
+pkgname=$_pkgname-git
+pkgver=LATEST
+pkgrel=1
+pkgdesc="Automation wrappers for po4a"
+arch=('i686' 'x86_64')
+url="https://github.com/skybon/po4a-bulk"
+license=('GPL')
+depends=('po4a')
+provides=("$_pkgname")
+source=("git+https://github.com/skybon/$_gitname.git")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_gitname"
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+package() {
+ cd "$srcdir/$_gitname"
+ install -Dm755 po4a-bulk-gettextize.sh "$pkgdir/usr/bin/po4a-bulk-gettextize"
+ install -Dm755 po4a-bulk-translate.sh "$pkgdir/usr/bin/po4a-bulk-translate"
+}