summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabio Di Matteo2016-03-07 10:10:36 +0100
committerFabio Di Matteo2016-03-07 10:10:36 +0100
commit73f30669f177bbfb04940b900d6f43389fea16e3 (patch)
tree81ac648456f71a3ccdfca7b9002ce6a009728190
downloadaur-73f30669f177bbfb04940b900d6f43389fea16e3.tar.gz
Initial import
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD38
2 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d9301610253b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = pobvnc
+ pkgdesc = Pobvnc is an application that enables you to help other people behind a firewall.
+ pkgver = 0.1
+ pkgrel = 1
+ url = http://www.freemedialab.org/pobvnc/
+ arch = i686
+ arch = x86_64
+ groups = Network
+ license = GPL
+ makedepends = cmake
+ depends = gtk2
+ depends = x11vnc
+ depends = tigervnc
+ optdepends = curl
+ provides = pobvnc
+ conflicts = pobvnc
+ options = strip
+ source = https://github.com/pobfdm/pobvnc/archive/master.zip
+ md5sums = SKIP
+
+pkgname = pobvnc
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..43c2606e8a0a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Fabio Di Matteo <pobfdm@gmail.com>
+pkgname=pobvnc
+pkgver=0.1
+pkgrel=1
+epoch=
+pkgdesc="Pobvnc is an application that enables you to help other people behind a firewall."
+arch=('i686' 'x86_64')
+url="http://www.freemedialab.org/pobvnc/"
+license=('GPL')
+groups=('Network')
+depends=('gtk2' 'x11vnc' 'tigervnc')
+makedepends=('cmake')
+checkdepends=()
+optdepends=('curl')
+provides=('pobvnc')
+conflicts=('pobvnc')
+replaces=()
+backup=()
+options=( 'strip')
+install=
+changelog=
+#source=($pkgname-$pkgver.tar.gz)
+noextract=()
+source=(https://github.com/pobfdm/pobvnc/archive/master.zip)
+md5sums=('SKIP') #generate with 'makepkg -g'
+
+
+build() {
+ cd "$srcdir/pobvnc-master"
+ cmake .
+ make
+}
+
+
+package() {
+ cd "$srcdir/pobvnc-master"
+ make DESTDIR="$pkgdir/" install
+}