summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarco Pompili2015-09-28 16:23:16 +0200
committerMarco Pompili2015-09-28 16:23:16 +0200
commit58229f1772a413da0a4cda84c4d6a61521d32279 (patch)
treeff4e110871fcb36657252b5aa6d756e7b0d5a2c3
parent77d06811f3e6829620c6810725d213cda6772e0a (diff)
downloadaur-58229f1772a413da0a4cda84c4d6a61521d32279.tar.gz
Version 5-prealpha
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD33
-rw-r--r--cython2_makefile.patch9
3 files changed, 25 insertions, 33 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bd5f7a44006e..f71421e113ac 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,21 @@
pkgbase = pocketsphinx
pkgdesc = Lightweight speech recognition engine, specifically tuned for handheld and mobile devices, though it works equally well on the desktop.
- pkgver = 0.8
- pkgrel = 5
+ pkgver = 5prealpha
+ pkgrel = 1
url = http://cmusphinx.sourceforge.net
arch = i686
arch = x86_64
- license = custom
- depends = sphinxbase>=0.8
+ license = BSD-2
+ depends = sphinxbase=5prealpha
depends = python2
depends = gstreamer0.10-base
depends = libpulse
depends = libsamplerate
options = !libtool
- source = http://downloads.sourceforge.net/cmusphinx/pocketsphinx-0.8.tar.gz
- source = cython2_makefile.patch
- md5sums = 9f6fb6277d57fb33d2c49d4184587d26
- md5sums = 7524229c5d82c49a5c4afabd7f891a65
+ source = http://downloads.sourceforge.net/cmusphinx/pocketsphinx-5prealpha.tar.gz
+ source = https://raw.githubusercontent.com/cmusphinx/pocketsphinx/master/LICENSE
+ md5sums = e8402e90570935b26745d313c133b376
+ md5sums = 93bfe6b712fe592d844ef581e1e53d47
pkgname = pocketsphinx
diff --git a/PKGBUILD b/PKGBUILD
index e95e9c4a2f83..8b9959c923bf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,18 @@
-# Maintainer: Marco Pompili < marcs DOT pompili AT gmail.com>
+# Maintainer: Marco Pompili <marcs DOT pompili AT gmail DOT com>
# Contributor: Ben Duffield <bavardage AT archlinux.us>
pkgname=pocketsphinx
-pkgver=0.8
-pkgrel=5
+pkgver=5prealpha
+pkgrel=1
pkgdesc='Lightweight speech recognition engine, specifically tuned for handheld and mobile devices, though it works equally well on the desktop.'
arch=('i686' 'x86_64')
url='http://cmusphinx.sourceforge.net'
-depends=('sphinxbase>=0.8' 'python2' 'gstreamer0.10-base' 'libpulse' 'libsamplerate')
-license=('custom')
-source=("http://downloads.sourceforge.net/cmusphinx/$pkgname-$pkgver.tar.gz" "cython2_makefile.patch")
-md5sums=('9f6fb6277d57fb33d2c49d4184587d26'
- '7524229c5d82c49a5c4afabd7f891a65')
+depends=('sphinxbase=5prealpha' 'python2' 'gstreamer0.10-base' 'libpulse' 'libsamplerate')
+license=('BSD-2')
+source=("http://downloads.sourceforge.net/cmusphinx/$pkgname-$pkgver.tar.gz"
+ "https://raw.githubusercontent.com/cmusphinx/pocketsphinx/master/LICENSE")
+md5sums=('e8402e90570935b26745d313c133b376'
+ '93bfe6b712fe592d844ef581e1e53d47')
options=('!libtool')
build() {
@@ -23,10 +24,6 @@ build() {
find -type f -exec sed -i 's_python-config_python2-config_' {} \;
find -type f -exec sed -i 's_cython_cython2_' {} \;
- #sed -i '/cython/s/$(CPPFLAGS) -I$(sphinxbase)\/python/$(SphinxBase_CFLAGS)/' python/Makefile.am
-
- patch -Np1 -i ${srcdir}/cython2_makefile.patch
-
export PYTHON=/usr/bin/python2
export PYTHON_CONFIG=/usr/bin/python2-config
@@ -34,14 +31,18 @@ build() {
--prefix=/usr \
--with-sphinxbase=auto \
--with-python=/usr/bin/python2
- make
+ make
}
package() {
cd $pkgname-$pkgver
make DESTDIR="$pkgdir" install
-
- install -d "$pkgdir/usr/share/licenses/$pkgname"
- install -m644 COPYING "$pkgdir/usr/share/licenses/$pkgname"
+
+ install -d -m755 "$pkgdir/usr/share/licenses/$pkgname"
+ install -D -m644 "${srcdir}/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+
+ libtool --finish "$pkgdir/usr/lib"
+ libtool --finish "$pkgdir/usr/lib/gstreamer-1.0"
+ libtool --finish "$pkgdir/usr/lib/python2.7/site-packages/pocketsphinx"
}
diff --git a/cython2_makefile.patch b/cython2_makefile.patch
deleted file mode 100644
index 16704049946d..000000000000
--- a/cython2_makefile.patch
+++ /dev/null
@@ -1,9 +0,0 @@
---- pocketsphinx-0.8/python/Makefile.am 2015-05-30 11:56:43.247774183 +0200
-+++ pocketsphinx-0.8/python/Makefile.am.cython2_fix 2015-05-30 11:58:15.540146568 +0200
-@@ -40,5 +40,5 @@
-
- if BUILD_CYTHON
- $(srcdir)/pocketsphinx.c: $(srcdir)/pocketsphinx.pyx $(srcdir)/pocketsphinx.pxd
-- cython2 -o $@ $< $(CPPFLAGS) -I$(sphinxbase)/python
-+ cython2 -o $@ $< $(SphinxBase_CFLAGS)
- endif